Mini external USB stereo speaker not detected on boot


I recently bought these speakers for a project. While they worked perfectly with a Raspberry Pi 3, I have been having some issues getting them to work with a Raspberry Pi Zero 2 W running 64 bit bullsye. The issue is that on boot the speakers are not detected. I have to unplug and replug the speakers in for them to be detected. Wondering if any one else has experienced this issue and managed to get past it? Unfortunately my googling has not turned up much in the way of a solution.



Just an update on this. I have discovered that the non-detection issue only occurs when a reboot is done via sudo reboot. If I simple turn the power on and off again on the Pi, the speakers are detected.

1 Like

Ok some more info.

My last update mentioned that turning the pi off and on again rather than running sudo reboot will see the usb detected on boot, this is true about 8/10 times. There are instances where the usb device is still not detected. I am running lsusb to confirm the device is indeed not detected.

Also, to add further info I missed earlier. I am using this OTG cable.

Hi @Samuel266024 - welcome to the forums :slight_smile:

Sounds like a perplexing problem! after some light research I came across this StackOverflow post where the user rebinds the USB hub using the crontab @reboot.

It feels like a bit of a hack, but may be prudent to do in this case. Given that a full power-cycle is needed, it sounds like the powered state of the CPU / USB device is creating the issue and rebinding the peripheral could do the trick.

Thanks heaps! Yeh it is a bit hacky but I am not having much luck with other approaches. I got one last thing I am going to try and if that also fails it will be crontab time.