Official 7inch Touch Screen, Touch not working when used with POE+ Hat

Hi All
My configuration is as follows
PI4B 2Gb
Official 7inch Touch Screen CE04459
Raspberry Pi PoE+ HAT CE07841

My issue is when using POE Hat the screen will not sense touch input however it displays fine.
You can touch the screen anywhere on the screen and nothing happens.

I am currently running the latest version of Bullseye 64bit with all updates installed.
Have also tried lite version with same result and noobs.

The power and gnd for the display are soldered to the io pins 4 (5V) & 6 (Gnd), to ensure a positive contact when hat is installed.

I have also tried running the power for the screen off one of the usb ports on the pi to the micro usb on the screen board and the result is the same.

If I remove the Hat, and power directly through the USB C on the Pi the screen behaves correctly and all works fine.

I am in the need to use POE as the kiosk location does not have power close and this is a good solution if I can get it working.

I would appreciate any feedback

1 Like

Ok So I have found a solution. it appears the issue is with Bullseye. I found a post with similar issues on the raspberrypi forums (official 7" LCD touchscreen does not work when powered with raspberry PI POE HAT 4A output - Raspberry Pi Forums) and it appears using legacy Buster works … all appears to be working as it should now.



Hi Neil,

Thankyou for posting the solution once you found what the issue was so others can avoid the same trap!
I was aware that some versions of Raspberry Pi OS didn’t work with some 3rd party touchscreens (something to do with the way drivers are handled in Bullseye vs Buster) I did not expect two official Raspberry Pi components to fall foul of OS compatibility issues.

Hopefully, the issue is patched soon.

Hi Trent also found another solution … make sure pi is fully updated and then edit “sudo nano /boot/config.txt”.
Find string

# Enable DRM VC4 V3D driver

and edit to be 

# Enable DRM VC4 V3D driver

I’m not sure the last line is needed but from what I have read changing the first line to fkms uses the older driver.

seems to work now with Bullseye.

1 Like