Raspberry Pi display touch input not working

I have one of the official raspberry pi displays (Pi Foundation PiTFT - 7" Touchscreen Display for Raspberry Pi | Core Electronics Australia) and have had all sorts of issues getting the touch input to work reliably. Occasionally it will work and continue to work until I have to reboot my pi. Most of the time it then doesn’t work once it has booted back up again. I then have to reboot a few times and it sometimes comes back. The fact that it has worked suggests I have everything connected up correctly, but not sure why it only works some of the time.

I have tried everything that is mentioned here: https://windowsreport.com/raspberry-pi-touchscreen-no-work/ I haven’t been able to see anything the dmesg output or the /proc/cmdline file even when the screen has been working. Maybe its not detecting something correctly?

I have the official USB power supply. I have also tried powering the pi and the screen off two different USB power supplies, I have also tried powering the screen using the jumper and/or the usb connection. I have tried re-seating all the ribbon cables a few times, but nothing seems to make much difference.

The system is a raspberry pi b 4 with 2gb ram, running the raspbian bullseye release.

Is the anything else I could try?


Hi Steve,

Can you please share a photo of your hardware setup? Sometimes a second set of eyes may spot something small that could make all the difference.
Intermittent problems like this are tricky to isolate, I can’t think of anything obvious that’s missing.
Just to confirm, you still had the issue while using an official Pi power supply and having the touchscreen power connected to the Pi via the included jumper wires?
Intermittent issues are often related to power supply or grounding problems but there is nothing you have mentioned so far that indicates what could be causing the touch sensitivity to drop out.

Hi Trent,
Thanks for the response. Please see a couple of photos below:

Yes, the issue was still present using an official pi power supply and using the jumper wires. That is the only configuration I have got it to work in, however it still doesn’t work most of the time.

Let me know if you need any more info.

Hi Stephen.
Try a new set of jumper wires. It is not unknown to have a bad crimp and has been the culprit before (on this forum actually). If that cures the problem get rid of the suspect ones permanently and get them out of circulation. Don’t even bother to try to find the suspect.
Cheers Bob

1 Like

Hi Bob,
Thanks for the idea. Just tried a couple of different sets of jumper wires and still no luck. I think my SD card might be on the blink a little bit, it has done some weird stuff in the past and I have just lost all the task bar icons (clock, network status etc), so that might be the next thing I try.

Hi Stephen
Was just a thought. Also some of these jumpers have female sockets which can really suffer if continually pushed onto the fairly large header pins. It would appear the material is not up to that sort of treatment and the springy bit does not return fully to the original point and can be quite loose when a smaller pin is inserted. I stress that some, not necessarily all exhibit this problem.
Cheers Bob

Hi All,
So got a new SD Card today and that seems to have sorted it. Put the latest raspberry pi image on it and screen worked first time, could even use it to go through the first time start up process. After I had done that I shut it down and put the old card back in, touch screen didn’t work. It also runs much faster than with the old card, so think it was definitely on the way out. Thanks everyone for the help.


1 Like