Pi OLED stopped working

I recently set up my pi zero as a pi-hole with the Pi OLED displaying some stats (https://learn.adafruit.com/pi-hole-ad-blocker-with-pi-zero-w/overview-adafruit2). It worked perfectly for about 24 hours and now the OLED is not working.

When I run ‘sudo i2cdetect -y 1’ I get the below.


The Pi OLED is warm so I expect it is still getting power.

Do you have any suggestions???

The Pi OLED working

Hi Hayden,

Hmm, that seems a bit strange, although it’s hard to see what’s going on with the display in that picture. When you say it’s not working, is it just not receiving any new data, or does it just display nothing? Could you put up a clearer shot?

That was a photo of the PiOLED when it was working, it is not displaying anything on the screen at the moment.

Hmm. The first thing I would try is a fresh image. It’s the quickest way to eliminate a software issue.

Done, that now. Still nothing showing on the OLED

Hi Hayden,

Not a problem. If you reply to your order confirmation with a link to this forum post, we can go from there.