Pi zero W problem

I’ve just purchased a pi zero w board. I initially loaded Jessie Lite on it, and everything ran fine via SSH. I then tried to install some software, but lost network connectivity during the installs (my fault) and now I can’t seem to get the board to run properly.

I reinstalled Jessie Lite on my sdcard, and when it starts, the board prompts for a login and password, but then does nothing at all after I enter the password - nothing else is displayed on the screen. I downloaded Jessie Lite again and loaded it onto my sdcard again, but no change.

I then installed (“non-Lite”) Jessie and tried booting that. It boots properly and displays the desktop, but neither mouse nor keyboard work.

I’ve tried using another sdcard, but with the same result.

Does anyone have any ideas about what I might have broken? And how I might fix it?

Hey @Peter36994, that sounds super-frustrating :confused:

When weird early-boot problems arise, I’ve found it’s always best to rule out power and storage first:

  • What power source is powering the Pi? What is its voltage and current rating?
  • What are the capacity and make of your SD cards?

I guess it’s safe to say for now that the Pi functions properly since you were able to SSH and begin installing packages.

How are your keyboard and mouse connected? ie. what type are they and are they powered if necessary?

Hi, Michael. The power supply and sdcard were both supplied by Core as part of a pi zero w kit. The power supply is the official one - should have plenty of power. The sdcard Core supplied doesn’t seem to be the issue because another sdcard does exactly the same thing.

The keyboard and mouse are just plain usb devices, and work perfectly on a pc.

I only want to use the pi zero w headless anyway, so I followed your headless tutorial. Everything worked fine initially, but now I can’t get past the logon/password prompts. Initially, a couple of paragraphs of text were displayed followed by a command line prompt. Now, when I hit enter after the password, I get nothing at all. So it’s not really an early-boot problem, more like a post-boot problem.

@Peter36994, I’ve found a blog that describes similar symptoms to yours - SSH hanging after login. The outcome was to modify a file within the Raspbian filesystem, which is probably out of the question if you’re on a Windows machine.

That still doesn’t explain why a USB keyboard doesn’t work. Have you tried Rasbian Lite with only a keyboard and monitor plugged into the Pi?

EDIT: I’ll include the steps here for posterity.

After some investigation we have determined that this a combination of two issues. One the latest version of SSH installed on the Raspberry Pi 3 uses QoS headers to ensure speedy delivery of packets over the network. For interactive connections (standard shell SSH connections) it sets the IP header for IP_TOS to be 0x10 (low delay or latency). For non-interactive connections (scp, etc) it sets the IP header for IP_TOS to be 0x08 (max throughput).

The problem in our case seems to be that our network doesn’t really like those values. We aren’t sure if this issue is with the router itself, or something in between. Since this connection is occurring over WiFi and our router handles the Wifi, we suspect that the router is where the issue lies though.

Additionally, we were able to determine that this impacted both SSH and SSHd, so both incoming and outgoing SSH connections were impacted by this issue.

Edit the two configuration files for the Raspberry Pi:


And add the following line to the bottom of the configuration file:

IPQoS 0x00

And restart sshd (sudo service sshd restart).

This configuration change will modify the TOS value sent out by SSH and SSHd, and will no longer choke the network connection.

Hi, Michael. I can’t change those settings when I can’t log on :frowning:

However, I do have another (different brand) access point available here, so I’ve hooked it up and connected to it, and now I can log in!

I might eventually try changing the settings that the blog guy talks about, but for now I just need to stop wasting any more time on the problem and get on with actually using my pi 0 w.

Since I don’t need to use a keyboard and mouse (my project is headless), I also don’t want to waste any more time looking into that.

Good to hear, @Peter36994. Lucky you had a compatible AP spare.

If you have a project in the works, document it over on our Projects module for some sweet store credit!