Raspberry Pi Zero W WiFi issue


I received my Pi Zero W 2 days ago. I have spent literally 30+ hours trying to connect it to wifi but have not been successful.
I burned a fresh image of RASPBIAN STRETCH LITE from https://www.raspberrypi.org/downloads/raspbian/ using win21diskimager.

I followed these instructions from different guides

  1. https://core-electronics.com.au/tutorials/raspberry-pi-zerow-headless-wifi-setup.html
  2. https://www.youtube.com/watch?v=LlCr09B2HZI
  3. and many more

I added the 2 files ssh and wpa_supplicant.conf (with my network details something like the one below)


After the boot these files get deleted and get added to /etc directory. I checked the file wpa_supplicant.conf and it contained the same data like the one above.

I left the pi alone for 5 minutes and then tried to check my network and it still wouldn’t show up.
Then I tried to ssh to the pi and even that failed.

I desperately need some help now as I will be using the pi for homebridge.
Network connectivity is very important for that.

Thanks in advance :slight_smile:

Hi Swapneel,

Hmm, sorry to hear that you’re having issues setting up your Pi. I’d recommend trying it via the GUI rather than as a headless setup. Connect it up to a monitor via a mini-HDMI connector, and connect to your network as you would any other computer. That’ll help work out if it’s an error on the board, or your process.

Hi Sam,
Thanks for your reply, I spend the entire day today trying to fix the issue and looked around for the correct cables, and I finally managed to get the pi online. But now the new problem is that it keeps loosing Wifi connectivity. I tied to connect it to my iPhone’s hotspot (which was next to it) and I got the same results.
I am now suspecting that there is a hardware fault.
What do you think?

Hi @Swapneel53105,

Sounds like you’ve done everything you can! Reply to your order confirmation email and link to this forum topic. We’ll get this sorted out.

Hi @Graham
I have done as requested.

1 Like