Picade Hat not powering on

Hi all,

Just got my Picade hat and tried to hook it up to a couple of Pi’s I have (a 2 and a 3), but I can’t get it to power the board on. I have a 2.4A supply that will power up the Pi itself fine, but will not power up via the hat.

I’ve checked that the GPIO pins are engaging properly into the hat, and that there is no other shorting happening (i.e. pins shorting on the HDMI plug).

I’ve read elsewhere that these have had power problems, so wondering it mine has the same.

Any thoughts?



Hi Tim,

Just to confirm, you are applying a brief 3-5V signal to the soft-power pin?

This is needed to turn it on (even without software installed on the Pi, it’s a hardware feature)


Oh don’t tell me it was that easy!! :slight_smile:

Will give it a stab tonight. I must have been following an overly-simplified guide. Is there a schematic/setup diagram available online somewhere? I was searching high and low and couldn’t find one (edit: there is a guide at https://learn.pimoroni.com/tutorial/picade/build but looks like a different board - ie. has 2 speakers - but doesn’t mention the soft power button)

Edit again: Are you sure you’re mean to apply voltage to that pin? I’ve looked at these instructions: https://shop.pimoroni.com/products/picade-hat and I can’t see how that would be. Looks like that just needs to be earthed.

Thanks for the quick response, guys!


Problem solved… earthed the ‘power’ back to the ‘earth’ pin on the ‘utility’ interface and it worked.



1 Like

Nice! Thanks for reporting back :slight_smile: