Picade Monitor Doesn't Work :(

Hey guys!

I ordered my picade kit from you last week and it arrived Monday (woo!). I’ve put it all together perfectly, hooked up my Raspberry Pi3, I hear the sounds of the booting aaaaaaaaaaaaand… no image. The monitor flicks white and then off. A couple times it’s flicked blue and then off. The led on the control board flicks green and red. I’ve tried powering it off and on, but same thing over and over. Also, yes, I’ve changed the config.txt as per the instructions.

I’ve had the pi for some time and it works with no issue, I hooked it up to another HDMI device just to make sure, and that all worked fine, so I imagine it’s an issue with the monitor/cables/boards that came with the kit. Is there any way to get any replacement parts or anything like that to try to replace and get it working?

Thanks guys, love your work! Matt

Hi Matt, hmm sorry to hear you’re having issues with your PiCade, what did you chance in the config.txt file? Also have you tried another HDMI cable?

G’day Sam!

Thanks for a fast response mate.

I did try another HDMI cable but same deal unfortunately.

The config.txt file I just changed was this, as per instructions from Pimoroni:
If you’re a Raspberry Pi user, we’re currently recommending RetroPie as the OS of choice to run on your Picade.

After installing RetroPie on an SD card, and before booting it up, make sure you edit your /boot/config.txt and add or uncomment ( remove the # before ) hdmi_force_hotplug=1.

Since the display is powered from the Pi it wont be properly detected at startup, so this is required to make it work."

I had tried this with and without changing this, but same deal unfortunately.

Thanks mate

Are you using the official 2.5A power supply? Also a common error which is hard to spot which can cause this issue is the ribbon connector to the control board. Try unseating the control board from the pegs, and completely disconnect the ribbon cable from the control board and the screen, then using some pliers, firmly re-attach it and make sure it’s 100% connected.

Yep, I have the 2.5A supply. And I’ve tried all of the reconnecting. I had done a bit of research and found a few other forums suggesting similar things and tried it all, but unfortunately still no go :frowning:

Yeah that’s one of the most common causes, have you had a look through this forum post which outlines some possible causes?

That was the exact post I was reading through last night! I hadn’t tried messing with that part because I know nothing about power and amps and all that jazz so I didn’t want to risk blowing anything up any further. I’d be happy to try that after work tonight to see if it’s any fix. Would I just need to change max_usb_current=1 to max_usb_current=1.2?

Yeah it can be a bit daunting fiddling with that kind of stuff. Having said that, we didn’t need to do any of that for our Picade unit in our warehouse, so I wouldn’t think it would be that causing the issue. Try that though, and let us know if it fixes anything.

For sure, I’ll try that tonight and report back afterwards. Thanks mate.

Hi Sam. Got home and tried all of that, same deal unfortunately :frowning:

Hi Matt,
Hmm that doesn’t sound good. Shoot us a reply email to your order confirmation and we can help sort this out :slight_smile:

Sure thing mate, I’ll do that now. Thank you!

Done and done :slight_smile: Thanks Sam

Just replied to your email @Matt22064 Matt, I’ll check out your Picade and see what the issue was, then post here with the fix for anyone else that may have a similar issue.

Thanks Sam! Will you need the speakers as well? And you’ll want my personal RasPi too correct?

Don’t worry about the speakers, and yep the Rapsberry Pi and everything with it.