Pirate Audio no sound

I’ve raised this on Pimoroni’s site (https://forums.pimoroni.com/t/pirate-audio-no-sound/14679/2) , but had little response.
I’ve set up the HAT and it worked OK with mopidy for some time while I worked on some code to play some MP3s and display a photo in response to some extra buttons. I tried a few iterations of hardware and ended up adding a Hack3r as the best way to fit things in a case.
Somewhere along the line the AMP stopped amping and and I have gone through a fresh Raspbian and mopidy install. I thought for a while GPIO25 (the DAC enable) had died, but that tests OK.

On the software side I expected mopidy to log somewhere if it failed to communicate with the DAC, but
I can find no references to that, so I’m not sure it’s hardware either.
BUT I’m left wondering: do I find a Header for my other PiZero and see if that makes any difference, or try another Pirate HAT, or do I dig deeper into mopidy?

Hi Dave,

Mopidy is just a music server, it doesn’t interface with the hardware, so it may well be running just fine.

The Pirate Audio HATs use the HiFiBerry drivers (which are included in the Pi Linux Kernel).

It may have something to do with this:

Try rolling back to an older version of Raspbian and see if that fixes the issue. Unfortunately I don’t have one here to test out.

Exactly which Pirate Audio card are you using?

Support | Core Electronics

Hi Oliver,
the main change from the hifiberry link was to comment out dtparm=audio=on. Both scripts I’ve tried (Pimoroni’s and Adafruit’s) seem to handle that… anyhow tried it both ways and no fix…

I’m running raspbain ‘Buster’, kernel 5.4.51 and that hasn’t changed since I was first running the Pirate board. FYI it the 3W amp version that I’m using.

As for mopidy, I guess I’m hoping for some error checking to say it got no response or something. Also, the behavior in the WWW (iris) is that the ‘play’ runs for 3-4 seconds then back to zero, which seems like it’s having a buffering problem.

I’ll try a different SD card.

1 Like

I’ve gone back to a basic install with a different SD card. Still no sound output and iris is looping every 3-4 seconds.

BTW the pi was updating the kernel (without exactly telling me!) when the installation said it was doing a Software Update and going to the 5.4.51 kernel, so I skipped that and the problems exists with 4.19.118+


1 Like

this is looking more like hardware. I tried Volumio and still no sound.
4.19.118+ kernel and Raspbian Jessie.


1 Like

New hardware (Pirate HAT) works with volumio. doing more testing.