Pirate radio not working after install of software on script

Pirate radio project not working , I can test the speaker with Speaker -test and get sound but can not get the music to be played from the My playlists
no sound at all .

Hi Brian,

Sorry to hear you’re having issues, but welcome to the forums!

It looks like you’ve posted a link to your local server which won’t work for us. What software are you trying to use? Pimoroni have a few different tutorials for different software to use on these:

Good morning Oliver,
I am looking to use the Spotify software and it seems to be working. , it is pulling down playlist and music but still an issue with sound.
open to helping as I want to use the radio to study by and I start next week?
any advice
kind regards

1 Like

have you ran an update lately
apt update && apt full-upgrade.
after it is done reboot it
once it boots check over all the sound property’s,if it has options then look at them all …
.excuse me for my poor knowledge of pirate radio… i never used it …but if your using it as software then an update may just solve a lot of issues…

1 Like

I will try it tonight.
Thanks for the suggestion. I will let you know how it goes

1 Like

Hi Brian,

Sounds like an odd one, I would double-check the GPIO connections (the 40 pins on the Raspberry Pi board) and ensuring you have a Premium Spotify account.

I was taking a look at Pimoroni’s site here: Streaming Spotify to your Pi - Pimoroni Yarr-niversity

Let me know how you go!


PS: I have removed the personal details you have posted, in future you dont have to post it! we can get back to you on here :smiley:

1 Like

good evening ,
no luck applied patching and can play speaker-test . and get sound but nothing out of the iris
IS there anyway to get some diagnostics happen to the problem ? I would be disappointed if i have to send this back to you. but i have been trouble shooting and done the install multi times now to no outcome .
sound test works so what is being missed in the configuration file ?

Hi Brian,

How interesting, if you’re not getting any audio from the Pi at all from any application then it may be an issue with the setup in Raspi-Config forcing the audio to the HDMI rather than the 3.5mm jack. There’s a tutorial to set this up from the link below, but the general idea is to open sudo raspi-config after the usual sudo apt-get update && upgrade then ensure that the audio is forced to the appropriate port before restarting the Pi. If you do continue to run into issues due to the Pi not being functional please include the link to this forum post in a reply to your order confirmation email and we’ll get this sorted out right away. All the best with the Pi! Make sure to let us know how you go!

No still no luck on getting this to work. I will borrow a PI from work and build as a stand-alone tonight to check the build process. My Pi is not one with a 3.5 mm jack on the PI. Could this be the issue?

Hi Brian,

We just got your email. I’ve just removed the order numbers from the forum post as it’s personal information. Let us know how you go with the other Pi, I’ll get back to your message now.

morning team,
I have been working on this, and it sees the scripts are built for a prior version of python?
will look at running this in a prior version to test if it works


sudo apt update
sudo apt install python*
sudo apt full-upgrade

into your system may be an easy way to cover a lot of bases although this is very broad in its install if your not shore which version of python the code is using…it will not install any version that is not already installed thus the “*” at the end after python package…but i seem to have pointed into the right direction for others to adapt from…it will most likely throw the broken or missing packages errors… there not that critical and thus the full-upgrade install

if you run into trouble with a package that seems to fail use this code

sudo dpkg-reconfigure "package name"
dpkg --configure -a
apt -f install

Hi Brian,

Just to cover all of the bases, I’ll send through some checks that other makers have done for their Pirate Radios.

sudo apt update
sudo apt install python3 idle3
  • The latest version of Iris is installed from this guide here
  • The latest version of Modipy-Spotify is installed with this guide here
  • You have a Spotify Premium Account with a device login so that you are able to access the songs using the Python library

I also had a dig around the Pimoroni Forums to no avail.

I’m not sure if using a student account would affect it :confused: .

Let us know how you go with the above tests.

Best of luck,

1 Like

Good morning Liam
I have worked through you recommendations and no luck.
still no sound.
Is there a way I can get one of you to test this build as I have studies next week and would like my radio to work.
kind regards

Hey Brian,

Certainly, send Core a reply to your order confirmation email, drop the link to this forum post in the email and we can get this return sorted out!

Kindest regards,

1 Like

Hi Brian,

I have gotten one from stock to test. The two things I can think of are:

  1. follow these steps on manually setting the audio:
    GitHub - pimoroni/pirate-audio: Examples and documentation for the Pirate Audio range of Raspberry Pi add-ons - Under the install heading

  2. The other thing is that it sounds like you are trying to access Spotify playlists, to eliminate problems can you please test by downloading an Mp3 file to your pi and going through the browse section on Modipy?

Please let me know how both of these go.

A very good morning support team,
I tried this last night and no luck, still the same get a speaker test to work but no music. on point 2 I am looking to move some MP3 tonight to the Modipy local store. just need to set up WinSCP to move them tonight.
will update once done. you mentioned a system in the office you tested did it work?

1 Like

Good afternoon Brian,

Yes, I believe Mitchell was running that one for you, I’ll leave a message for him to get back to you when he’s in next. Sometimes it helps to clear everything and just start fresh going through the tutorials on the part for the first time and then develop to what you need from there. Best of luck with the project! Make sure to let us know how you go. :grin:

1 Like

Hi Brian,

Definitely let us know how the mp3 goes. The main thing is that if you can hear the test music through the output on the pirate audio hat, it means the issue is software. Thus, testing the mp3 is important.

If you could also send a photo of your setup this could be helpful as well.

1 Like

you hear sound…can you strean sound…?? against the fact that you have sound in storage this tells me is your issue getting from or should i say out of storage cleanly… it has to only be one of three things it seems to me …have you checked the wiring…?? is there any other receivers you could use and likewise with the tx-mitter… do you see where i`m coming from …i think you delving in to deep the answer is in front of you ,hence did you buy these units brand new,…??? have you used them before are all battery’s in good health…i think is like there is a config file that has not been put into the rc.local if you will… there is a key to a door missing or the door has mover…isd it the holes moving or is it there electrons… …?? walk away from it for a few hours get some sleep… think freshly,!!