Raspberry Pi Rain Radar & Weather Dashboard


Thanks for the reply… I was looking for the output from these commands on your RPi:

node -v
npm -v

It will show the versions of each (like I have in my last post to Tim)

1 Like

Sorry about that

Node v14.19.3
Npm v6.14.17

1 Like


I finally figured out the source of my problem… but I can’t take credit for it.

At this link on the Pi Weather Github, fcrwx posted he was having the same problem but resolved it by changing the code which identifies your location. So I updated my config and entered my lat/lon manually and as soon as I did, the map and radar data immediately started working.

I did this on both v12 and v14 of Node so that does not seem to have any impact. Sure would have been A LOT easier to find the source of the problem if the app generated log/error files :slight_smile:

1 Like

@Tim and all,
I’ve just been down a similar path.
Setup… Old Pi2B, and ‘waveshare’ 7 inch display, using Putty to edit files and Win10 to search stuff.

Things I found helpful:
The Pi Weather Station page saying unable to find stuff and did you enter the API keys, and showing a spinner was not actually refreshing while testing them out.

Entering any rough Lat and Long helped a lot…

https://pimylifeup.com/raspberry-pi-kiosk/ has step by step instructions for kiosk mode, BUT chromium was not at /usr/bin/chromium-browser (delete ‘-browser’).

The second script.sh here https://stackoverflow.com/questions/64353905/running-npm-start-from-execstart-in-systemctl-service-file got over NPM problems.

Running sudo journalctl -xfu weather in a terminal while starting the service, picked up some errors in my typing.




Which API is which key?

Maps = Mapbox?
Weather = Tomorrow.io?
Geolocation = LocationIQ?

I get an error “cannot retrieve map data, did you enter an API key?”

1 Like

Hey Ian,

You’ve correctly figured out the API to the Key. Sometimes it takes a couple of hours on the API side of things to confirm and send your desired weather data out. It should be all good to go now, just make sure you have an internet connection to your setup and the API data is perfectly written. From your Error message the API which is causing issue is the MapBox one.

Kind regards,

1 Like

Tim, can i ask a question?

If the loop is turned on, i see the radar image moving. but when the loop is stopped, no radar data is displayed. i am looking to have just the current radar image showing, then an update every few minutes. so the current radar is only showing.

does that make sense? Ideas or suggestions would be appreicated.

1 Like

Heyya Robert,

This discussion on the main GitHub page for this Raspberry Pi Rain Radar should point you the right direction - Adjustments to weather API call rates · Issue #20 · elewin/pi-weather-station · GitHub

All the code is open source so you will be able to update the rain radar once every 10 minutes or so/slow down the animation process to 1 Frame every 10 minutes. This is the section of the code that manages that process —> pi-weather-station/index.js at master · ABUCKY0/pi-weather-station · GitHub

Adjusting the constant | const MAP_CYCLE_RATE = 1000; //ms | in your Raspberry Pi System to a number significantly higher and then running webpack from the command line, it will read the updates you made in the source files and generate a new bundle.min.js file for you. Then your changes will be understood by the system and you should be good to go :blush:.

Kind regards,

1 Like

hey, i followed everything in the video but after i put in the api keys, i waited for hours for it to activate but its still not loading the maps or weather info. its just a loading animation. pls help Thanks!

1 Like

Heyya mate,

I think you raised this question in the YouTube Comments. My tip for you initially is to use a more powerful power supply. It looks to me like the Raspberry Pi is having current issues/voltage issues.

After that is solved I bet it’ll perform as it should :blush:.
Kind regards,


your       pm2 start npm --start     does not work anymore 

pm2 start 'npm start'     works 
1 Like

Is this project still monitored? If so, I just built it today and the code runs. However, I cannot get it to display full-screen on my 3.5" TFT resistive screen. When I run it in a terminal window, it opens up Chrome and displays the WX screen, but not full screen. I still see the rest of the desktop on the pi. Is this project only built for the 7" display? Thanks!

Hello, thank you for putting this guide together. I am using the latest bullseye version of raspberry pi os. I got it all working after I entered the starting lat and long by hand. The one thing that I do not have are labels on the map. Is there a way to nail that down? Cheers

How do I add a location name instead of cords, it takes up space and is sorta ugly. Any ideas?

Looks like a nice little device, however I am unable to make it work - I get to the point of adding the keys and I can’t view the bottom of the setup screen where the ‘save’ box is, therefore I am unable to save the keys. Scrolling the screen just moves the background, it does not move the settings box. Tried this now on 2 different Pi’s (3 and 4), both with the ‘official’ 7" screen and get the same problem on both. Too bad, looks like a nifty gadget.