RasPi zero w for controlling Tesla wall charger

Having some trouble getting my new rpi zero w to work in headless mode. The project I’m following on-line is to control a Tesla wall charger. The software was written on 2017-11-29-raspbian-stretch-lite.img and I have loaded it to a new 16GB mini SD card using 32DiskImager (Etcher didn’t work, Dialog box said file was corrupted but 32DiskImager seemd to work OK). I’ve added a SSH and WPA.Supllicant.conf files to the boot drive but when I install the card in the Pi and use Putty to connect it says it cant find the host. Any ideas?

1 Like

It can be a bit tricky getting headless to work.

Suggest connection of monitor and keyboard to the Pi Zero.
This will allow you to see if the Pi is actually working.

I am surprised Etcher does not work, it is my go to preference; when it says the card or file is corrupt, its usually correct. 32DiskImager has seemed to work in the past for me but when I tried it in the Pi, it did not boot. Other times it did work ok; my main use of it is to create a backup image of the Pi micro SD card when development is complete.

The information in WPA supplicant must be your router SSID and pass phrase. You will need the IP address the router assigns the the Pi for use with Putty (port22). If the router dynamically assigns IP addresses then it may be different when the Pi boots up. I have set my router to assign a static address so I know which IP it is using every time.

Just some thoughts, all the best in getting it to work.


1 Like

Many thanks Jim. I had to give up on the combination of 2017 software image, WINZIP and Etcher. It kept suggesting the img file was corrupted so I reformatted the SD card deleting the partitions, and downloaded the latest version of lite OS (2020-08-20-raspios-buster-armhf-lite.zip) along with ‘Raspberry Pi Imager’ from the official website.
The file unzipped OK, RPi Imager worked well and I was able to image the SD card with the OS. Subsequently, I transferred the card to the pi and added the script files for SSH. That also worked OK and I was able to configure the pi and download the code for the Tesla Wall Connector project from https://github.com/dracoventions/TWCManager
The next step is modifying the code for API calls to the Fronius solar inverter. Wish me luck…

Hi Bernie and James,

Glad to hear you managed get it working! It’s always great to see everyone helping each other out :slight_smile:

Support | Core Electronics