Rii mouse speed not controllable

I bought an Rii wireless mouse and keyboard for use with my Raspberry Pi.
The keyboard works fine.
The mouse speed cannot be controlled by the DPI button, or by the mouse/keyboard controls in Raspian.
The acceleration speed is fixed at ultra slow.
Another wireless mouse using a separate dongle works properly, controlled by Raspian.
If the Rii mouse is compatible with the Pi, I suspect a faulty mouse, but would appreciate advice in case there is a solution.
Regards: Ian

Hi Ian,

Could you try this:


to /boot/cmdline.txt
in the same line separated from the other stuff by spaces


1 Like

Thank you Steven, that worked.

as below::

    sudo nano /boot/cmdline.txt

This is one very long line of text. Enter (Rii keyboard ) to get to the end of it
and add a space and usbhid.mousepoll=0

Enter ^x (control x), Y to accept change to save.
Now reboot:

   sudo reboot

The mouse now works OK

1 Like

Stephen - my reply did not reproduce correctly as your system apparently does not like angular brackets which I used for key combinations. I suppose it still makes sense.
Rgds: Ian

All good, I spotted the formatting issue and made a quick fix :slight_smile:

Thanks for reporting back that everything worked out.

Thanks for checking back in Ian! Glad you got everything working.

me issue
Rii wireless mouse lags on RP4 8g unit i purchased yesterday and have done all the updates and up grades. mouse lagged.
I then went through the internet and came across the above suggestion
after using nano as above i have changed the cmdline.txt
however even after several reboots i have had no luck at resolving.
works fine on my laptop

Solved - thank you all here,
I carefully read back over all the instructions and realised i had not used a space but a return.
thus my line of code was on a new line not appended to the existing line.
I now realise what was said earlier about being a long line of text
cheers Ian