Core Electronics Forum

RPi system update error

Hi - I have attempted to update my RPi OS to the latest release – Bullseye. The update has ended in an error:

 *sudo apt-get install -y gparted*
*Reading package lists... Done*
*Building dependency tree       *
*Reading state information... Done*
*Some packages could not be installed. This may mean that you have*
*requested an impossible situation or if you are using the unstable*
*distribution that some required packages have not yet been created*
*or been moved out of Incoming.*
*The following information may help to resolve the situation:*

*The following packages have unmet dependencies:*
* libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6+rpi1 is to be installed*
*E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.*

As a complete novice here, can anyone suggest what is happening and hopefully how to fix it. Cheers Stu

2 Likes

Here is the solution

sudo apt install gcc-8-base

If you’re trying to upgrade from Buster to Bullseye, it is a pain, gets lots of errors and then PI menu bar disappears, etc, etc. Worst is, the little Raspberry Pi (start menu equivalent) disappears. So, unless you know the Terminal commands very well, difficult to get anything done. I tried the above as well but then went in for a clean install.

Just backup the Documents, Downloads, bookmarks, if possible browser config and passwords and other special scripts you have to an USB drive or somewhere.

Use the RPI imager in RPI to do a new OS micro SD card using an external drive. Switch off RPi and switch the SD card and copy back the files from the external USB drives to the respective folders.

A lot easier took me about 10 minutes.

If you have Mathematica installed, uninstall it. It takes a long time (about 700MB size) to download from the RPi repository.

6 Likes

Clean install of the OS is my plan.
OS upgrades have never worked perfectly on other OS systems.
Always something that is not quite right.

Its annoying to have to start from scratch but the time saved is worth it in my opinion.

Cheers
Jim

4 Likes

Hi Stu,

Some of the early releases of Bullseye did have some known issues which have been patched out over time. How recent is the version that you’ve flashed to your card?

2 Likes

Hi Bryce – I’ve been away from this for a while, babysitting duties :slight_smile: However, since revisiting today, I now have an additional problem … I can no longer boot my RPi, it just hangs after the splash screen. In reply to your question, which OP system are you referring to? The RPi was bought with and is currently on Buster, I tried to update to Bullseye and then it all went to hell …

1 Like

for the most part the image breaks in the upgrade process …i cannot remember exactly but you break the xserver system or along those lines…often if you do not upgrade correctly …it can be done but often tricky if the kernel release is not adequate or along those lines to fully meet the on the fly upgrade…always a fresh image is the best always and in general with Debian releases are somewhat extensively tested to work first time… Vs other spin offs of the linux platform…
try dropping to a console and logging in as root user and run a full update and full upgrade…!!!
alt +F2 key should bring up a console…
most common fix around these days…!!!