RPi4 password wrong & no VNC

Hi all,
Recently purchased RPi4 8GB and trying to setup. Have purchased two x sd cards (16GB and 32 GB) of NOOBS from Core.
Having an issue with networks and passwords. Help from Core [Bryce, Mitchell and others] has not been able to resolve and suggestion to post here.

Configuration: Apple MacBook Pro (Big Sur) connected to RPi using Thunderbolt Ethernet to Ethernet (RPi) in Headless mode (no monitor HDMI or other monitor on my boat other than MacBook or iPad’s. No ‘router’ either so no ‘WIFI networks’ so as to speak. Using ‘hotspot’ from phone to get Mac to internet.

Issue 1. Cannot get network settings to stick after shutdown and restart but another topic I guess (not priority thought - see Issue 2 below.

Can get raspberrypi.local ip address using terminal mode with command arp -a. Find raspberrypi.local and ip address. Can then ping RPi successfully.

Objective is to get to RPi desktop to set up VNC permanently for auto boot to desktop on MacBook (development environment).

Resource: Using Section 3 headless on boot. SSH (Secure Shell) - Raspberry Pi Documentation as one of the principle guides.

command ssh pi@ returns prompt for password [with key symbol]. All password attempts have failed. Using any sudo command also prompts for password and similarly all fail. Have setup ssh folder several times. Have tried to connect via ssh (passwordless) using public keys (have generated).

Each and every time I get the prompt for password [with key smbol] and this is where i get stuck.

Any thoughts would be most welcome.

1 Like

SOLVED. Apparently [referring to RPi Org doco] when connecting headless and using an ethernet cable between client and RPI4 the password keyed might require the keyboard locale to be English-PC. The @ symbol is down at Shift-" and with that the password was accepted.

ADDITIONAL For completeness of answer.

RPi 4 now working on MAC Book Pro 15" (mid 2015) via CAT6 cable connecting MAC Book Thunderbolt - Ethernet adaptor to RPi Ethernet port. Set at full 1GB/s.

The Mac was using its internal keyboard with the AU setting originally and its internal trackpad/or the attached wireless mouse (HP) and the standard retina display.

With respect to the post topic - regardless of what I saw on the screen being typed, and it looked OK, when it came to the RPi, user Pi, password whenever a sudo or similar root command was used, it required me to have the keyboard locale in British-PC. What I did notice of course is that the @ is Shift ’ on the British keyboard.

That is not all. The ethernet connection was flaky and I could never (command line) get the RPi to ‘fix’ a static IP address. Thats just my lack of skill. ALL the tutorials etc were assuming that there was a ‘network’ of some sort (i.e. network name, group etc) with many of the commands not delivering anything like the examples. So looking in the MAC Network connections or using the terminal really didn’t assist in fixing it. They [variously] did give me the ‘current’ RPi IP address as it kept changing on RPi reboot. Typically I saw something like 169.254.nnn.nn. or even once. I kept trying with the current list until I got a successful ping. The Ethernet connection was never fully green (it was occasionally) but if I could get a ping then I could log in.

Finally I am in and working on the desktop of the RPi4, via a cable between Mac and RPi (not other network, no WIFI or BT). To get this working I needed to:

a. change keyboard input source to British-PC (just for the period to get the VNC working),

b. get ip of RPi. Mac terminal > netstar -nr. Then ping raspberrypi.local or the ip address to confirm active on this session of ethernet. When OK. To ssh pi@raspberrypi.local. Password with UK keyboard required at this point. Then RPi local up. sudo raspy-config to get to configuration menus. Configured the locale, speed, boot up, turn on predictable interface names, ssh on, vnc on, updated the software (note that the MAC was ‘hot spotted’ to my iPhone in order to have internet connection), and then restarted RPi.

c. Apple-G to launch the VNC (built into Big Sur). I got the IP address and when i tried I got a warning that the VNC was not compatible. Researched and I then downloaded a new VNC ([VNC Viewer 6.21.118 Real VNC].

d. subsequently got a warning “VNC cannot currently show the desktop”. Needed RPi to boot to the desktop [selected …and already be logged in option] and that the screen resolution needed to be set as high as possible (from cl sudo raspy-config option).

There are articles about this on the web as far back as 2014 I think. Still no joy.

e. More research and downloaded a new desktop for RPi. LXDE I think - at command line inside the RPi using sudo apt-get install lxsession. Rebooted.

f. Back into the MAC, used the new VNC and pop - right into the RPi desktop.

The desktop launched straight into some configuration items which I followed all the way through including setting up a good password. Changed a RPi password setting to use the VNC Password instead of the Unix one and set a strong password for this. Turned encryption always on so that more than just the first 8 characters of VNC used. Set Pi user password to ‘remember’ so that the long string is not required to log on each time. Also set the new VNC server on the MAC to require a Master password for each ‘session’. Again using a strong password.

So ultimately we are into desktop on reboot & launch of VNC on MacBook Pro. Well twice in a row - not a statistically good number but will take if for now. Still cannot get ‘internet’ to the RPi when at that desktop so that is the next challenge.

In summary; ip, keyboard to get login then sudo config (changed settings and got latest software (4Feb2021)), new vnc on Mac, new desktop on RPi, changed RPi screen resolution to max. Rebooted RPi then restarted MAC and launched VNC. Pinged for latest IP and then VNC in and it worked.

Hope this helps someone.

Hey Michael,

Thanks for calling to let us know about the issue I apologize that we didn’t see this post sooner usually we try to be live with forum responses during the week. I’ve linked a couple other forums and pages up here to help others with similar issues when they see this as well as some instructions for how to configure their keyboards to the appropriate localization. Glad to hear that you’ve identified and fixed up the issue :slightly_smiling_face: If there’s anything that we can do for you please let us know. Have a great day!


1 Like

FINAL SAY… after several days of working through various issues not related to this post directly I find I am nearly back to square one in some ways. Final position with above ‘image’.

Could turn easily and regularly work with headless RPi4 and MacBook Pro via Ethernet and VNC.

Process: turn on RPi before rebooting Mac. RPi with full Raspberry OS configured SSH and VNC on; working on boot up and single authentication into RPi from Mac using VNC authentication [encryption always on in my case]. Updated and installed many items on RPi using command line so that ‘internet’ was available because country WIFI credentials were never accepted and no matter where (from various/numerous forums) I located the ‘supplicant.conf’ document; the command > sudo raspiconfig approach (cl mode) or via the GUI using menu Raspberry Pi configuration the ‘AU’ (for Australia), details would not be accepted (lots of forum activity available). I did successfully change the Locale to Australia, and the keyboard to Australian International, but never any luck with the third item in the list being the WIFI setup.

VNC would ‘freeze’ as soon as I turned on ‘sharing’ - internet… (using ethernet in P2P arrangement). Both MacBook network connection and the RPi would no longer respond although Mac mouse and keyboard remained active and I could jump to desktop of Mac and continue with whatever. Reboot of Pi would allow VNC back up and could then get back in again. Could share almost everything else fine but never the ‘internet’. Some forum activity around that this may be a recent ‘iPhone’ hotspot thing??.

I had configured numerous items and upgrades but wanted to install some GitHub software for a three relay HAT in order to ‘learn’ investigate and learn some details towards my real world application.

Downloaded the latest distribution of the ‘source’ (per Raspberry Pi org) and installed it. This was an interesting experience and not completely satisfactory. During this process (release notes) it was recommended to update the pi and do a full upgrade. Did this and it no longer responded. Furthermore no matter what I tried I could get it to come up on the link (ethernet) and could not find the ip address no matter what (ping, network commands, ifconfig, arp etc etc).

Bottom line is after three days of trying (approx 15 - 20 hours of actual work) I downloaded a new (approx 1GB) image of Raspberry OS (32bit) via mobile phone and started afresh. I went and purchased a monitor (Philips HDMI) and a RPi official keyboard and mouse (red/white ones). Installed the sd card and turned it on. During boot I got the screen splash etc) and this time however during the initial setup configuration I accepted the WIFI step. Immediately I saw my mobile phone hotspot appear (it was being used by another device so it was staying ‘alive’ so i could grab it - authenticated in and immediately on the web. Have got back to where I was previously within an hour or so. A very satisfying experience compared to the initial one.

IN SUMMARY - whilst it is completely ‘do-able’: headless with P2P via ethernet (and it is shockingly fast), it was always a struggle (newbie) and without GUI web access it made it somewhat confidence knocking. For what it is worth ($'s for keyboard, mouse and any HDMI monitor) I would thoroughly recommend connecting directly to the Pi in the first instance in order to get on top of all the other learning required without putting hurdles in your own path (like password, ssh, VNC and wifi problems etc).

Thoroughly looking forward to getting the NMEA2000 - SignalK server - Victron Energy VenusGX and my RPi4 (‘management system’) all working on our sailing boat home.

1 Like