Slow Wifi on Raspberry Pi 4 (8GB)

Hi all,

I’ve installed clean Raspberry Pi OS (Debian Buster from May 2020) and connected to home wifi. I get over 20 Mbps on my laptop or phone but brand new Pi barely gets over 0.6 Mbps on 2.4GHz network, 5GHz is even worse. I tried removing it from Argon NEO case but that didn’t help. Any ideas what is going on?

Thank you.

With those speeds I suggest you invest in a new router.
I am using an Asus RT-AX88U and on 5g my pi 4 is in an argon neo case getting 390mb connection.

I’m getting slow internet on my pi4 as well. Initially, it was working okay. But now, it seems to be getting worse. I don’t know why.
I resorted to connecting the internet to the router with an ethernet cable, but it is still slow. My Windows PC that I’ve owned for a number of years now works with the router fine (wireless connection).

I was using a Pi3B+ before, and it was okay until I updated to the new Pi OS 32bit. I resorted to getting a Pi 4 8GB in the hope it was simply a lack of RAM causing the slow speed, but there is still a problem.

Any help on configuring the internet on the Pi4 would be greatly appreciated… even if you can direct me toward a relevant tutorial or blog.

Got a photo of how you’ve got it set up? Like all things RF, there’s usually something weird involved.

Check out this thread on linux questions:

Hi @Oliver33, thanks for your reply.
I’m actually on the RPi4 now connected to the internet, and so far, things are running okay.

According to the documentation for setting up the GPU on the website, it is recommended to use 256(MB) as the GPU memory allocation… this was part of the problem.

I also needed to have the I2C enabled in the Pi configuration. Don’t ask me why, I’m no way near a level in I.T for understanding what this has to do with it.

The other thing I do is I make sure I click on the WiFi icon and disconnect before shutting down the Pi. When I switch the Pi on again, I allow the boot up to complete before I click on the WiFi icon to switch the connection back on.

These things have helped so far… the only glitch I have is initially opening up my browser (I’m using Firefox).

1 Like

Hey Matt,

Glad to hear that the issues are resolved. Thanks for adding this to the forum, hopefully, it will help others with the same issues in the future. If there’s anything else that we can do for you please let us know.

Core Electronics | Support

1 Like

I forgot to mention the name of your wifi router… only use letters and numbers, NO special characters like underscores.
Same deal if you decide to change your Pi’s name from the default ‘raspberry’… This you should do for added security.


As well as changing the SU password.

Core Electronics | Support

1 Like