Core Electronics Forum

Stepper Driver Tic T825 error

Dear all
First post and first try with Steppers
Have a Tic T825 driver board and a Linux Mint system
Cant get past first base - computer will not recognize the board via USB

On the board Red fault LED is on continuously
Green flashing about 0.5 sec on/off
Orange same but at different time (indicates no motor power supply) - this should not matter

Have loaded the permissions file to /etc/udev/rules.d/99-polulu.rules
I note there is no device ID and no group in the file

Anyone had a similar problem and/or solution?
Does anyone know the device ID?

Thanks
Richard

2 Likes

Are you sure? The DRV8825 chip that this module uses gets its logic power from the motor supply. Without a motor supply the logic won’t be running, and presumably it wouldn’t respond to the USB interface.

2 Likes

Hi Oliver,

Sorry to hear it’s giving you trouble! Could you post photos of your setup if Jeff’s suggestion doesn’t work?

Keen to see it working!
-James

1 Like

Thanks for the responses
Shame job
It was the USB lead - I tried 4 and they are obviously all the power only type
Found a fifth one and it worked

Richard

3 Likes

Thanks Jeff
I just wanted to see the USB
The ticgui program seems to work without a motor supply
I think the motor supply drives the (presumably) H bridge which drives the motor coils directly
but not much else
Anyway working now

R

3 Likes