USB Audio Adaptor

I am having trouble with an ADA1475 USB Audio Adaptor received recently with a Raspberry Pi 3 Model B+ order.

I have read the Adafruit tutorial and tried both the speaker test and microphone test. The adaptor red light flashes but I hear nothing, and it receives nothing from the microphone. That indicates to me that the set up is correct (otherwise the red light would not flash). I have also tried it on another Linux computer with same result.

I have tried a generic microphone headset and also ear buds, both with 3.5mm stereo jacks.

Am I using the wrong jacks, or can you suggest what I might be doing wrong?

Thanks, David

Hi David,

What does the device report as using dmesg?

Hi Graham

GeneralPlus USB Audio Device

I’m not familiar with that outcome - the Adafruit guide suggests the chipset should report as CM109. CM108 or CM-Headphone. They list how-to guides based on each of those scenarios, noting that they are only tested on Raspbian

Correct. I went through their guide and noted that the chipset is not any that they list.

So I didn’t make any of the changes they list for those chipsets.

Nevertheless, the device is recognised:

dmesg shows where it is loaded

lsusb lists it

aplay -l shows it

and I can set it in Preferences>Audio Device Settings including as Default.

Then if I try speaker-test the red light flashes but no audio.

Cheers David, good to know.

If you have already tried with a fresh copy of Raspbian, then it might be worth replying to your order confirmation email to arrange a return. Link to this forum topic if so

Thanks Graham. I have also raised a support ticket with Adafruit and will see if they come back with anything useful.

Thanks Graham
Nothing from Adafruit which is disappointing. So I have emailed a request for return.

Interestingly, I also plugged it into a Windows machine (a generic USB adaptor should work in Windows, MacOS or Linux). No audio when a play a wav file or video. But when I tried sound test and increased the gain to the max, there was a faint, almost indistinguishable “ding”.

So something weird is definitely going on and it does not conform to the Adafruit documentation.

Kind regards, David

1 Like

Hi Graham
I received the replacement unit yesterday and am pleased to advise that it works.
It does not conform to the Adafruit documentation. The manufacturer is Generalplus Technology Inc. not C-Media Electronics Inc. and the chipset is not reported. Just the same as the first unit I received.
It is not necessary to make any manual changes in Raspbian Stretch. Just use Audio Settings Preferences to set controls and assign it as the default sound device.
Thanks for your help.
Regards, David