Waveshare 2.13 inch e-paper for Raspberry Pi Pico not working

I have tried to test this module with the demo program from Waveshare’s Github, “Pico_ePaper-2.13_V3”, as this matches the version number of the board. However when I run the program through Thonny the printout in the shell repeats “busy” and “busy release” until the code stops and the screen doesn’t activate. Trying to figure out if it’s a hardware or software issue. I’ve tried loading the Pico with the UF2 version from the Waveshare Github as well as the most recent release, but having the same issue with both.

1 Like

Welcome to the forum Will!

Before reviewing the provided code, could you please send through a photo of how you have your Pico and screen setup?
PS: The product page shows the pico mounted correctly: E-Paper E-Ink Display Module (B) for Raspberry Pi Pico, 2.13inch, Red / Black / White, SPI (212×104) | Waveshare | Core Electronics Australia

Thanks for your response Trent, here are some photos of the mounted board.

Hi Will,

Thanks for providing those photos, looks like you’ve got a 3rd party Pico variant. Do you have a link to some documentation for it, just so we can check the extra onboard LED isn’t messing with the pins the Waveshare display is trying to use?
We need to make sure the SPI pins required in the image below aren’t being used for some other function or have an alternative mapping in your Picos setup.

Since you were getting an error message earlier about “busy” and “busy release” I think GP13 could be particularly important here.

I’m sorry for the poor quality, but this is the documentation from the site I bought it from.