Witty Pi 3 Rev 2 Not Detected by Raspberry Pi

Hi Guys,

I bought a Witty Pi 3 Rev. 2 and part of the instructions in the manual from Uugear is to ‘Configure Bluetooth to use mini-UART (Raspberry Pi 3 only).’ How exactly do I do this?

Manual reference: https://www.uugear.com/doc/WittyPi3Rev2_UserManual.pdf

I am using a Pi Zero 2W and from my understanding it uses Pi 3 architecture and therefore it maybe applies to this device.

I think it may apply since when I try enter into the Witty’s shell file interface it returns “Seems Witty Pi board is not connected? Quitting…”

The board is definitely connected by the GPIO pins and the Pi is actually being powered through the Witty’s power port.

Note: at this stage it does not suggest anywhere it is compatible with Pi Zero 2W however it works with all Pi’s across the board so I would assume it is just outdated specifications that were made before the Pi Zero 2W was released.

Your help would be much appreciated!

1 Like

Hi Samuil,

I haven’t used the Witty Pi gear myself but that documentation is top-notch.

Generally speaking the different Pi hardware behaves the same for the end-user but there are a couple of implementation differences that sometimes cause issues (Like when the Bullseye camera libraries didn’t run on the Pi 3 boards because a different driver was missing).

I suspect the instruction to “Configure Bluetooth to use mini-UART (Raspberry Pi 3 only)” is because of a slight hardware difference. I’ve found this article that explains some differences in how the Pi 3 boards handle UART.

In particular, GPIO14 and GPIO15 are impacted which is hardware the WittyPi is trying to use.

Was there any other hardware connected to your Pi Zero 2 W or just the Witty Pi?

Hi Trent,

Thank you for sharing that info.

I followed the procedure and it appears to still not be working (enabled serial was already done, but I also swapper over the port by disabling Bluetooth all together with the ‘or’ option: dtoverlay = pi3-disable-bt

Still getting the same problem of the WittyPi not being detected though :confused:

I am using a SIM7600g-h modem which strictly uses the 5V/GND/USB+/- pads. Using that for the USB ports since I am running the OS on a SSD (don’t have a micro usb reader currently) but would presume this should cause no problems.

I confirmed the Witty Pi does work on a Pi4 though but for my use case I need it to work with the Pi Zero 2W.

Hi Samuil,

I’m not aware of any other hardware differences that would be interfering.

I’d suggest chasing down a microSD card reader just so you can rule out the SIM7600g-h entirely as a contributing factor. The fewer parts there are in the system the easier it will be to prove where the fault lies.

If you’re still getting issues with the SIM7600g-h removed it would be worth reaching out to the manufacturer of the Witty Pi just to ask if anyone has it working with the Pi Zero 2 W yet. If they can confirm that someone has that combination working you will know better if it’s a hardware fault, or an incompatibility issue you are chasing.

Hi Trent,

I managed to use an old laptop to load Raspberry Pi OS onto a SD card and I am now connected in via SSH. I am still getting the same error unfortunately but at least that is all ruled out of the equation.

Could you please confirm if I mapped Serial 0/1 correctly? I have extracted a photo below:

Screenshot 2022-05-04 172941