WS2812B raspberry controller not working

Hi all.

I bought this WS2812B LED Strip (60 Leds/m) and followed the tutorial but the LED strip stays always the same: video

The Chip is a 74ls14 with NANDS.

Everything is well connected. I added a LED to see if the Din was getting some voltage and the LED changes. Tried also with a logical shifter with same behavior.

Does anyone now where is the problem? I am really desperate… I tried even with the neopixel library with no solution.

Thank you very much,

Hi Joan,

Are you able to provide a circuit diagram of what you are trying to wire up so that we can check it against this.

The circuit is the one you provided on the tutorial but instead of a level shifter I am using two nands to shift Voltage to 5 Volts.
GPIO18 to Pin1 of 74LS14. Pin2 to Pin 3. Pin4 to Din of LED strip.

Chip VCC is 5 Volts.

Hi Joan,

I would not expect this to work with NANDs, you will need to use a logic level shifter. What tutorial did you follow? Have you tried connecting everything exactly as shown in the tutorial? From your video it looks like there is a bad data connection to the LEDs. This would be expected given that you have an LED in the data line and that you are using NANDs rather than a level shifter. The timing tolerances on WS2812s is extremely tight, and easily corrupted. That LED you are using to test for signal would prevent any usable signal from reaching your LED strip.

I tried with the logical shifter but I will try it again without the LED to check the signal. I will let you know.

Thanks @Stephen.



I assume you are following

Also, it looks like you have the LED connected without a resistor, so it will DEFINITELY pull the signal line down and cause problems.
It would be easier to check your wiring if you use the same wire colours and layout as the tutorial. So try turning your proto board around, and re-wire everything so the Pi and 3.3V at the top and the 5V and LED strip is at the bottom.


@Stephen tried with the logical shifter but got no answer as usuall. Could the LED Strip be the problem? I bought 2 LED strips and both do not respond…

@dave50358, yes I followed the tutorial.

I bought a SP110E controller but they are also not working which is even more weird…

What can I check?


Two things to check:
I can’t quite see from your photo, but I’m not sure why you have four wires from the Pi and which pins they are plugged into.
and I can’t see where the GND for 3.3V is tied to GND for 5V (black wire on Left side of Fritzing diagram)


Hi all,

@dave50358 I connected two ground pins from Raspberry on the LV GND and HV GND.

I have bought another LED strip from amazon to see where the problem was and it seems there is a problem with the LED strip bought from aliexpress. The SP110E now works fine with the new strip.

I will try the circuit with the new LED strip to see if it works :smiley:

Does anyone know if this problem is a common problem buying LED strips from AliExpress? Cause I bought 3 strips and none of them worked.

Thanks all for your time and effort.


1 Like