8bitdo USB adapter freezing on Ubuntu (linux) after adapter firmware update to v1.18

Hello all,
I just purchased the neat little 8bitdo USB adapter from Core, and managed to have some success with it using the xboxdrv driver in Ubuntu 18.04. It also works fine on Windows. However after I decided to update the firmware from the shipped 1.16 to v1.18 using the standard 8bitdo update software (on windows) I’ve not been able to use it again on Ubuntu.

Seeing as Raspberry Pi and Linux share some software and behaviors, I thought I’d see if anyone here has encountered this sort of thing before either on Linux or Pi.

How does the problem on Ubuntu manifest?
As soon as a controller pairs with the USB adapter, the system freezes without delay. No input is accepted on any device - keyboard, mouse, controller. The computer then has to be restarted.

If the USB adapter is plugged in to the computer when the computer reboots, it will not boot up.

Tried other Linux machines?
Yes. The same behaviour is noted on them too - freezing, then needing a restart.

How about rolling back to the v1.16 firmware?
I’ve done that. The problem persists.

What about windows?
Using the adapter on a windows machine works completely fine still. It’s just not at all how I intended on using the device.

Thanks in advance for any help anyone can offer.


Hi Gerard,

I’ve read that you can update the firmware for 8bitdo products on Linux now. Perhaps try updating using the Linux method and seeing if that helps? It may be possible that the rollback is not actually rolling back the firmware. Try installing a very old firmware version then going back to the 1.16.

Hopefully we can find something that sticks!

I know this is an extremely old thread. Very sorry for not ever responding.

First of all thanks @Stephen for your prompt response.

For anyone who finds this with a similar issue, the solution was:

  • update the firmware with whatever method you like - linux or windows didn’t make a difference for me.
  • after the update, you need to switch the mode of the 8bitdo USB adapter, then switch it back to the mode you need. After that it worked perfectly.