Pycom Expansion Board3 stuck in DFU mode

I had been making good progress with the LoPy4 Nano gateway tutorial. Updated firmware on the expansion board and the LoPy. Got the gateway registered on TTN and working for a few minutes.

But when I tried to move the device to another port, the PC lost the USB port and the board stuck itself in bootloader mode. Windows won’t recognise the device and keeps beeping. I’ve tried re-installing the driver using the Zadig app and the DFU utility but nothing seems to work. I’m trying to get it to reload the USB serial (CDC) driver and go back into Application (normal) mode. Nothing doing.

Is there some other way to manually load the driver?

never mind, I’ve fixed the problem - had to use a Mac (!) which seemed more forgiving with the USB ports. The problem was that I couldn’t run DFU-Util in Win10 as it wouldn’t recognise the device. So it meant a lot of fiddling about with a Mac loading HomeBrew and working out how to specify the path to the downloaded firmware.
This updating firmware process is not for the fainthearted!

Hi Andrew,

Glad to hear you’re back on track! I’ve updated around 40 expansion boards in the last month or two, I’ve found every interesting use-case there is! The most annoying thing is how windows enumerates the device (and doesn’t allow access to it for short periods of time).

When updating firmware, S1 is held while USB is connected (which powers the board). You get 7 seconds of DFU-mode, though an untold amount of that is taken by Windows, doing its thing. Sometimes (not often) it has taken me 4-5 full-reconnects to get the cmd command to reconise the device exists (despite being visible in Zadig with the right USB ID). Other times it reconises it straight away, though the update hangs on 96% for a few seconds then fails.

Zadig is helpful in the sense that it reveals the USB ID straight away, allowing you to see what’s going on. I’ve seen boards where the application mode driver was overwritten and on top of that there was a hung firmware update. Every unusual use-case I’ve seen has been resolvable on a Windows machine to-date, though often not intuitive.

Hi Graham

sounds very much like my experience. In my case I couldn’t get Zadig to connect for long enough. And Windows kept retrying the port so that DFU-Util gave the message that there was no configurable device attached. I think I tried most/all the various combinations you mention. But the Linux machines were happy to sit looking at the device so that DFU-Util could run.

I’ve got the Nano gateway running and registered with TTN. The combination of the Pycomm and Atom seems a bit flaky compared to my experience with Sodaq and the Arduino IDE. But it’s possible that I damaged the LoPy4 because I powered it with the aerial connected to the wrong UFL socket (!). So it might be that the unit is not working properly, or it might just be that I’m not very good at clearing the memory out and loading programs.

I haven’t been able to get a device to connect to the gateway yet. I don’t know if this is because I haven’t set up the various EUIs correctly. I’m using a Sodaq Explorer and I’m not sure if it needs reflashing. There was some talk of this on the forums. Their documentation isn’t the greatest.

I’ve ordered a Laird Sentrius gateway as I’m keen to set up full TTN coverage in N Melbourne. The Nano gateway was just to get the feel of it all. So I guess I can try the LoPy4 as a node to this when it comes and connecting this may be a bit more straightforward than hacking the Sodaq code.

Thanks for the response. Nice to feel that there is some help around.

Cheers Andrew

Graham, not sure if you can advise me. In the process of running Zadiq I inadvertently updated my Bluetooth adapter driver to usbuser (the serial port for the pycom kept disabling itself and so Zadiq switched itself back to the first device). Now my Qualcomm9565 Bluetooth 4.0 thinks its a COM port and not a bluetooth device and so isn’t available. I have tried reinstalling the drivers but get a message that the most up to date are installed and so the installation quits. So its broken! It’s not a disaster as I don’t really use the Bluetooth on my PC but I would prefer to get it back. Any idea how I might do this.

Naturally I didn’t have a Win10 revert point set as I didn’t realise you have to turn this on!

Cheers, Andrew

I’ve fixed this problem with the help of the Dell techs. Thanks anyway.