8bitdo N30 firmware update stopped my controller turning on

I got a 8bitdo N30 recently and had some problems getting the controller to reliably connect to my nintendo switch. After updating the firmware through the 8bitdo firmware updater on mac, my controller wouldn’t turn on and the charge LED hasn’t come on since. I tried to disconnect and reconnect the battery and update the firmware again but the updater still wont pick up a USB signal and the controller won’t turn on.
Has anyone else encountered something similar with 8bitdo controllers? Open to any suggestions to get it working again

Hi Joseph,

Try to Press and hold L+R and then plug in USB cable to update the controller if it does not power on. Sometimes this can bring them back from the brink.

Let me know how it goes.

Hey thank you Stephen, just gave this a go but I’m still not getting any response from the controller.

Hey Joseph,

I did a bit more digging, here is a more verbose description of what to do in this situation:

1.Hold START button for 8-10sec to reset the controller.
2.Download the firmware file from: http://support.8bitdo.com/
3.Hold L1+R1+START = UPDATE MODE 4.Then connect the controller to your PC/macOS via the USB-C cable.
5.Click on “USB Update” and select “Firmware_SF30&SN30_Pro_XXX.dat”.
6.Un-plug when the upgrade process is done, then restart it before using.

Download and update the former firmware.

Try this and let me know how it goes. It seems like this is a common issue, with most people able to resolve it somehow (just not sure which way yet :slight_smile:)

1 Like

Sweet, just tried this and my controller’s alive again. Thanks Stephen, definitely bookmarking this thread in case I need to update again. Have a good one.