ADA 1150 Peristaltic Liquid Pump with Silicone Tubing not working

Hi team,

I just received two ADA 1150 Peristaltic Liquid Pump with Silicone Tubing last week.
Initially, I was thinking to setup a diffusion cell with circulating system.

However, before I could really get the pumps on the system, one of the pumps has stopped working.

I have taken a photo of the pumps for comparision. It was in the beginning stage when I just tried to circulate water through the tubes.

The good pump (left) gave good circulation with continuous flow but the broken pump did not show any.

With some physical inspections, the sound and rotation of both pumps are the same. The only difference I can see is the rotation of the rollers. Please see the photo below. When there was power supply, the roller in the peristaltic pump should be rotating but not for the broken pump (right) at this stage.

Please advise what the potential cause could be.

Thank you.


Hi Jeffrey,

It is possible that the motor shaft has become disconnected internally, is there anything on it that seems to have become uncliped?

Hi Clinton,

I just had a look on the pump and compare both of them. Everything is clipped.

The motor is working fine and the shaft is rotating.

Just had a talk with other colleagues, could it be the rollers inside?

As in the surface of rollers was worn by the friction of motor shaft, causing shaft and rollers are not intact enough to drive?

That’s the only thing we can think of as the motor is working fine.


Yeah, I suspect that is what has happened or that the drive gear has disconnected from the motor shaft. If you suspect the Pump has a manufacturing fault, reply to your original order confirmation and mention this post we can work out the best way to get you back on track.

I accendently pulled the persalisitic tubing a bit to much. COuld you let me know how to fix it. It is stuck inside

1 Like

Could it be the pump is going in the wrong direction. I don’t know the details of these pumps but I imagine that if the voltage is reversed the pump would go the wrong way.
Try reversing the jar with water in it and the empty one and see what happens.
Cheers Bob

1 Like

Welcome to the forums.

I don’t have one on hand I can check but the front plastic housing looks like it may be able to be unclipped so you can access the tubing to pull it back out again.

Hope this helps


Hi Diya,

Welcome to the forum!!


You can open up the inside of the pump by bending out these two retaining clips:

Disassemble and move the tube then reassemble the roller system (it can be a bit annoying).

1 Like

Hi All
My apologies everyone. The post I replied to was 3 1/2 years old and I did not notice.
Once again highlights the ill manners of people who don’t post a result and leave everyone in limbo not knowing if their advice was helpful or not.
Cheers Bob

Thank you so much for the useful info. It worked when you open the persalistic pump and reassemble(Though it was a bit annoying)…

1 Like

Hey, another question. The Arduino kit that I have received comes with a piezo buzzer. But the piezo buzzer that I needed doesn’t function and I suspect it is broken. Anyone know any alternatives or how I can check if the piezo buzzer is broken or not? Thanks!

Hi Diya,

What was the kit that you purchased? Even better if you know what specific piezo buzzer came in it. Its a bit hard to give you troubleshooting advice if we don’t know what specific part you are using.

My generic advice would be to create as simple of a circuit as possible between a power source (outputting a voltage your buzzer can handle) and your buzzer to make sure the problem is not being caused by something else in your project and so you can isolate just the buzzer. If it does not make a sound, that is when we can start to troubleshoot the buzzer directly.

Hope this helps!