Core Electronics Forum

Adafruit TFT won't turn on

Just purchased the Adafruit 1.3 Color TFT Bonnet for Raspberry Pi - 240x240 TFT + Joystick Add-on and can’t get it to turn on or operate in any way.

I’m extremely new to hardware (experienced with software) so I’ve almost definitely done something wrong on the hardware side. Likely soldering.

My question is: How do I figure out what is going wrong?

To help troubleshoot. I have done the following:

  • Installed Pi OS Lite on an SD card and plugged it into my Rasperry Pi Zero
  • Setup headless mode so I can ssh to the rpi
  • Soldered header pins to my rpi
  • Soldered a Pimoroni LiPo Shim to the pins (working perfectly)
  • Attached the TFT Bonnet to the top of the pins
  • Followed the Python installation instructions at this link
  • Tried running the scripts, but nothing seems to happen. There’s no evidence of power being supplied to the screen, or anything at all for that matter.

At the risk of embarrassing myself, I’ve included some photos of my pi that might reveal any obvious issues:

Thank you for any help :slight_smile:



2 Likes

i can only see one possible bad solder joint… it is the pin directly adjacent to the letter codes on the board 2abcd …it looks like it is not making a good contact with the pad if you blow up the image you will see it has a larger shadow than the rest of the pins…
on another note i see that …that pin has a single wire going to that pad.not shure what this feeds …
the notes and the pics on the product page seems a problem and the tutorial video seems to differ from the product however this may not effect the electrical connections …??.. my obs

edit::
you may have applied to much solder it is possible that the solder has flowed through the holes in the board excess solder underneath the or should i say between the board and the header …causing shorts… not having a schem in front of me… check for shorts between pin and pins all of them …only other way to fix if you find shorts is completely remove the header …pain i know and clear all shorts with solder wick… they may be both on the board and the pins… you really need a de-soldering gun if you have to travel this path…as holes are plated through…

4 Likes

Hmm, yep I agree with Brian. Maybe try retouching your solder joints :thinking:

The Lipo shim supposedly only uses GPIO 4, and that is unusued by the TFT hat so it should be good to go on that front.

Also, check that you don’t need to just turn the backlight on as mentioned here:

4 Likes

Thanks for the help @brian86770 and @Oliver33 !

I tried your suggestions to no avail, unfortunately :frowning: Only thing I haven’t tried yet is removing the header, which is going to suck.

2 Likes

the tft unit may be faulty…???..not shure of any quick testing of it…
i read a bit about not getting the code correct id go over the code before removing the header

it is rare though …also if you do have a multi-meter/continuity tester check pin between pin for shorts.this may aid you …

3 Likes

think this is what you need…

not shure if pics are mixed up or the content is …the pages differ. i think this is correct for your display according to what i read follow code here it cant hurt …

3 Likes

That’s the guide I’m using actually. (I linked the wrong one originally in my post, but I just went through this guide and made sure that I indeed followed it 100% correctly)

I might look into getting a multimeter to test the pins, since I’ll inevitably need one at some point anyway.

3 Likes

Hey Jarrod,

That sounds like a plan! Are there any other errors come up that you’ve noticed when you’ve got when trying to run the bonnet? Also which script are you using with this setup? I assume that it would be the same as the scripts included in that tutorial but always best to check :grinning_face_with_smiling_eyes:

Checking the different rails on the board is likely the best way to ensure that the board is being powered sufficiently from the Pi? Out of curiosity, which power supply are you using with the Pi? As long as it’s 5V from micro USB even with a little current it should be fine, but switching it out to ensure that you’re getting enough power to the Pi and peripherals as a quick test to ensure that it’s running correctly.

All the best with the project! If you find that the board is faulty please reply to your order confirmation email and the support staff should be able to help you out with that one right away!

2 Likes

Thanks for the help Bryce,

I’ve tested several 5V power supplies, none of them seem to get it working.

I have tried running the rgb_display_pillow_bonnet_buttons.py script on this page.
I also ran blinkatest.py from this page, which confirmed that CircuitPython is installed and working correctly, FWIW.

Checking the different rails on the board is likely the best way to ensure that the board is being powered sufficiently

What are rails, and how do I do this?

1 Like

Hi Jarrod,

It might seem a bit obvious but double-checking that SPI is enabled in config.txt and maybe even trying full RPi OS?

Might be worth a shot?

Liam.

1 Like

Haha, nothing is too obvious for me @Liam120347 I’m a complete newbie when it comes to this kind of thing.

I tried re-enabling SPI in the config, no luck unfortunately.

2 Likes

I don’t know if it means anything in this scenario, but I ran the pigpio tests and everything passed. I can upload the log of the tests if it means anything to anyone?

1 Like