Adafruit PiTFT Plus capacitive touch screen issues [Solved]


I’m running the Adafruit PiTFT plus on a Raspberry Pi 3 running Raspbian Stretch. At the moment, I am having issues where the the touchscreen is registering random touches all over the screen which leads to opening programs and making it unusable, even with a mouse attached. As soon as I disconnect the touchscreen, the problem goes away.

Currently, I have uninstalled and reinstalled the Adafruit supporting software ( as per this link ( setting it up as a HDMI mirror. Has anyone else had this issue or know how to fix this issue?


Hi Andrew,

What supply are you using to power the Raspberry Pi and TFT screen, I have seen cases of noisy supplies causing similar issues.

Hey Clinton

I tried two different supplies, one is the official Raspberry Pi power supplier (Manufacturer is Stontronics, 5.1V 2.5A) and I’ve also tried a Samsung 5V 2.0A mobile phone charger. I suspected the same thing from googling the issue, several people said the same thing but I can’t imagine the official raspberry Pi power supply would cause any issues? Thanks for your prompt reply!

The Raspberry Pi Official power supply can sometimes be a little noisy, or the power supply may have a bad ground. What version RPi are you using and have you tried re-imaging your SD with a clean install?



Have you checked your connections? See this article:

If that fails. Try this:

Let me know how it works!


Hey Stephen,

Thanks for your reply. Reading that post, it seems that the problem is with the STMP610 chipset which according to that post is used exclusively with the resistive touchscreen and not the capacitive:

“0 - First of all, do you really HAVE a STMPE610 chip? If your touchscreen is capacitive, you don’t! So, most likely you are using the wrong kernel for your screen. Stop reading this and check the correct download page. If your TFT is resistive, keep reading.”

I am using a Raspberry Pi 3 Model B. I haven’t tried re-imaging my SD with a clean install yet, I am trying to avoid that if possible but I will do it if there are no other solutions. I will try a few other things today and post if I can find a solution.

1 Like


Just letting you know the issue is solved. It was most definitely the power supply. I was able to run the touchscreen with no problems using the PiJuice battery module. I will have to find a well isolated power supply for the job in future. Thanks for your help!