Arduino NodeMcu V3

I Have Just received in my Mail the Arduino NodeMcu v3 board and i need help on how to download the driver and connect it to the wifi. I Have a 2020 Macbook pro so i Need a Driver to Support that Version of MacOs, And also i am hoping to use it to test the DHT-11 Temperature and humidity sensor module i bought. So i also need help on what pins and i think i have the code from a youtube Video.
And also i see that the NodeMcu v3 does not have a 5v Pin, So how will i Connect the DHT-11 Temp and Humidity sensor to the board.

Thank you

1 Like

Hi Marcus
If you enter “Arduino NodeMcu V3” into your web browser (I assume safari as I have) you will find lots of info on the subject. About 2,420,000 results. Must be something useful there. I have never heard of it until now although I do not read all of the Arduino news. I just looked and Core don’t seem to stock it although that does not mean there are no people who are familiar with it.
Cheers Bob

Ok but like what Driver do i downlaod all the ones i have tried have failed

Hi Marcus

I really have no idea. Someone else may be familiar with this unit. Probably have to wait and see.
cheers Bob

now it is saying this error message What does it mean? if you know
. Variables and constants in RAM (global, static), used 28268 / 80192 bytes (35%)
╠══ DATA 1496 initialized variables
╠══ RODATA 1004 constants
╚══ BSS 25768 zeroed variables
. Instruction RAM (IRAM_ATTR, ICACHE_RAM_ATTR), used 60343 / 65536 bytes (92%)
╠══ ICACHE 32768 reserved space for flash instruction cache
╚══ IRAM 27575 code in IRAM
. Code in flash (default, ICACHE_FLASH_ATTR), used 237748 / 1048576 bytes (22%)
╚══ IROM 237748 code in flash v3.0
Serial port /dev/cu.Bluetooth-Incoming-Port

A fatal error occurred: Failed to connect to ESP8266: Timed out waiting for packet header

Hi Marcus,

Out of interest, where did you get that NodeMCU board from?

Regardless, we can certainly try and help out. Looks like there isn’t much documentation around, but this tutorial suggests board communication errors are due to picking the wrong board when flashing:

I noticed you were using esptool to flash, just to confirm were you using it within the Arduino IDE?

Keen to get to the bottom of this with you!

1 Like

I don’t think this could be right. That port would only be correct If you are connecting the board by Bluetooth. If you are trying to do that I would suggest that you try a simple cable connection instead.

If that’s not what you are trying to do then have a look at all your USB ports and see if there’s one that seems more appropriate for your board.

Hi Jeff

That would be correct. I too use a Mac with Bluetooth switched on for keyboard and mouse and this comes up as an option when selecting portsThe one I select for a UNO R3 is “/dev/cu.usbmodem14601”.

I would agree with that. I have never tried to use that mostly because I have never had a Bluetooth type of Arduino etc.

Cheers Bob

1 Like

Hi Jeff, Marcus
Add on
I do note that if my UNO is not connected (with cable) the only option in “Ports” is the Bluetooth one. The USB option does not appear until the UNO is connected. Then both options are listed.
Cheers Bob

1 Like

Hi Bob,

It seems most likely the bluetooth port appearing in the COM port list is from an unrelated peripheral connected to the same PC. When I view my COM ports at home my UE Boom bluetooth speaker appears in Arduino IDE alongside any microcontrollers I have connected.

@Marcus251035 It goes without saying it is crucial you know exactly which COM port you are trying to send code to or you may brick a device and make it become unresponsive. The quickest way to test this is to check what COM ports are listed in the MAC equivalent of device manager, then unplug/power off one and see if the COM port you expect disappears.

1 Like

Hi Trent

Not sure about that. I have my keyboard and mouse connected via USB (Mac) so I switched off these devices so they disconnected and used a corded mouse. The Bluetooth option still appeared under “Ports” in the tools menu.
The UNO appears on my Mac thus;

It is under the heading "communications device. You will see that the manufacturer is Freetronics as it is actually a Freetronics Eleven. This entry disappears when I disconnect the UNO. As you say.
Cheers Bob

1 Like