Argon Fan HAT script with LibreELEC

I have an argon neo case with the argon fan hat, running on a pi4 and LibreELEC for software

Recently I had to format my SD and start again and I have tried the script listed on “curl | bash”

I SSH’d into my pi and ran the script but I’m getting error message “curl: (23) Failure writing output to destination”

Can anyone help?

Hey Adam,

Welcome to the forum!!

I would take a look at this guide over on Argon40’s website here, for installing the script.

If you run into any issues let us know and we’ll try and track down the issue and hopefully find a fix, the install process is pretty simple so it might be a deeper-rooted issue.


Argon One Setup Completed.

Too many errors from stdin
Changes take effect upon restart

Restarting afterwards shows no change

Hey Adam,

Could you post some screenshots-pictures of the errors you’re getting? Hopefully someone has run into this before…


Please see screenshot

1 Like

A small suggestion, have you read the script file to see what it does ?
Did you check the files it creates ?
Have you restarted to see if it works anyway ?

At the very end is this.

systemctl daemon-reload
systemctl enable $daemonname.service
systemctl start $daemonname.service

echo "***************************"
echo "Argon One Setup Completed."
echo "***************************"
if [ $needsshutdownedit -gt 0 ]
	nano $argononeshutdownscript
echo "Changes take effect upon restart"

It could be calling nano causes the issue.
Best bet read the script to understand it.

1 Like

have dabbled a little into this matter but other things on the drawing board atm

um had the fan running at full speed i got into the program or the file system but i found i could not do much as it is a read only system i tripped the transistor with a jumper base to emitter hardware hack…

Hi mate, I’ll try and learn what the script is doing at each step but I’m far from what you’d call a programmer

Yes I have rebooted after running

the script sets variables for file names etc.
The echo’s are where it writes out the contents of the file, the >> says write to the file
The end it enables the files to run as a service.

It is a great way to learn a bit about scripting and helps so much to fix these things yourself.

So google systemctl command to check the status of the service. $daemonname is a variable replacement so earlier in the script you will see where it is defined.
as an example this is at the start of the script daemonname=“argononed”
so you need to get the status of argononed from systemctl. If it errors it wasn’t created, if it gives a result you can see if it is started or not.

As you can see in the section I added the argon one setup completed appears on the screen. Then you get the other error so it would appear the issue is in the if section I pasted.



I am having the same issue. The Argon fan hat script fails to install because of an issue in an “if” statement. The guide above is for an ArgonOne. I can get that script to install just fine but it doesn’t work. I am not sure this is actually meant to work with the fan hat though as the fan hat still behaves as described when you do not have the script installed. IE it runs at 50% fan speed and the power button only works when you hold it down for 5 seconds.

Is anyone able to assist with a resolution to the issue in the Argon fan hat script itself? When I install the script I get the following error:
curl | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0bash: syntax error: unexpected “(” (expecting “fi”)
43 20537 43 8945 0 0 9597 0 0:00:02 --:–:-- 0:00:02 9587
curl: (23) Failure writing output to destination

If I download and try to run the script from the raspberry pi I get the same error.

Hoping someone can help.


1 Like

I got in touch with Joseph at Argon40 and he mentioned they have a new script & process.

211019_AR_IR REMOTE_INSTRUCTION MANUAL_20211019.pdf (2.0 MB)

The link in the guide goes to


Thanks. I am confused though as I do not have an argon remote? I have an Argon fan hat. Is it the same script? That script has the same issue as above though and doesn’t contain a resolution for me.

1 Like

Interesting! It took a couple of weeks to get the last update (not unusual with what’s going on around the world). I’ll report back when they get back to me.

1 Like