Core Electronics Forum

Argon One V2 Fan Script - Could not resolve host - Raspberry Pi Lite OS

Hi Everyone,

Hope someone can assist with my issue on Argon One V2 fan script. When I try to install using the script (curl https://download.argon40.com/argon1.sh | bash), I’m returned with a Could not resolve host: download.argon40.com error. I’m definitely connected to the internet as I’m using this Pi to run my Plex.

I’ve also tried downloading the script and run it directly but still the same issue.

Hi Maverick,

I was able to parse the URL through chrome, so in my experience curl should be able to grab it.

You might want try wget instead? It might also be helpful to just try downloading the file then running it once you’re sure its made it to you.

You can also try downloading it onto a thumb drive on another PC and running that from your Pi

Keen to see you back on track!
-James

Hi James,

Thanks for your response, much appreciated. I’ve also tried downloading the .sh file and running it but am getting the error:

Not sure why it looks like I’m not connected to the internet.

Hi Maverick,

While you definitely have LAN connectivity (I can see you’re SSHing in), either your package manager sources or DNS might be playing up. Pinging www.google.com or similar should reveal DNS issues, and hitting sudo apt update should sort out sources (unless the Pimoroni script calls for more, but it should handle adding them itself).

I’d also be interested to see your ifconfig info, and cat /etc/resolv.conf to see what your DNS is doing.

Keen to get you back on track!
-James