Brief Video outage when Argon Fan Hat kicks in (Argon NEO, RPi 4, LibreELEC)

I’ve reached out to Argon initially about this experience but wanted to get your opinion on this too. They’ve initially suggested that the Argon Fan Hat might be faulty but they are looking to see if they can replicate my issue. I await their follow-up response.

In the meantime, I was wondering whether you guys have experienced a similar brief (what I can only assume is a HDMI) outage… I can’t find anyone mentioning it. Essentially, this is what happens:

If the fan starts, from sitting idle, the video cuts out immediately for about two seconds. If media is playing then I’ll also notice that audio also cuts out at the same time, except that when video resumes, audio comes back at a lower volume and takes a minute or so to restore to the prior level… if I turn the volume up before it restores itself, the audio will become proportionately louder when it finally does go back to its prior state. Note: There is no disruption when the Fan Hat shuts itself back down.

This is the basic setup… nothing weird:

Raspberry Pi: RPi 4 (4 GB), no modifications.
OS: LibreELEC (with prerequisite Raspberry Pi Tools & System Tools addons installed)
Case: Argon NEO with Argon Fan Hat (generally with the lid off)
Config: argonone-config using Defaults thresholds

I’m still waiting on Argon 40. In the meantime, I’ve been doing some more testing. I still haven’t worked out what is causing the video outage when the fan starts from idle but I’m left with thinking that the NEO case just doesn’t like my TV…

This is what I’ve done so far…

I have another Raspberry Pi 4, it sits on my desk running Raspbian. So… I plugged the LibreElec Pi into the cables at my desk (ie, different power, network and HDMI)… I didn’t have the issue when I forced it to reach the CPU Temperature Threshold.

Next, I swapped the cases (to eliminate the Pi and OS)… I put the Raspbian OS Pi into the NEO with Fan Hat. I still didn’t have the issue on my desk… which implies that it’s something about the TV setup.

Next, I verified that Raspbian (now inside the NEO) also has the issue when connected to the TV… so then I tried switching out the Power and the HDMI cables at the TV… same issue. Note: Nothing else was plugged in… and these are Raspberry Pi branded HDMI and Power cables that came with the Pi 4.

As a last-ditch effort, I also tried turning off Sony’s version of CEC (Bravia Sync) just in case that was somehow impacting it… unfortunately, that had no impact.

Since I’ve now tried different cables and a different Pi with a different OS and it still happens, I’m at a complete loss… I’m left with somehow blaming the combination of the NEO and my seven-year-old Sony Bravia TV.

Is it possible the TV itself is reacting to something as the fan kicks in?

1 Like