Cant read voltages from Stepper Drive A4988

Hello, so I try to tune the A4988 driver , hooked everything like in your guide, but when I put my probe in the screwy thing and my black probe onto the ground, i get 0 V, nothing, the driver is powered trough the VDD i think it is called by 5v from arduino, but from the screwy thing i get nothing.

Any thoughts?

Hey Alex,
Welcome to the forums!

We can definitely help you debug this, first thing that may help us get you on track with your project is if you could include a couple of pictures on how you have got everything set up, we can check over your wiring to make sure its all good.

Second thing, could you share with us the code that you are running on the arduino so that we can get an idea of how the Arduino is meant to be interacting with the motor, just so we can see the whole picture and help you figure out what may need tweaking to get your project up and running.


1 Like

Hi Alex

You probably won’t get anything WRT ground. Try measuring the voltage across the windings Like A+ to A- or B+ to B-. Keep in mind you probably won’t see anything unless you are driving the stepper and it will be rapidly switched so don’t expect to read anything like full voltage. I am assuming you are using a DMM and they are quite slow ramping up to obtain a reading on even a steady voltage.

If the stepper is rotating then probably everything is OK.
Cheers Bob
PS Those “screwy things” are terminal blocks. If you don’t know what they do I would suggest putting everything back in the box until you find out.

I dont have a better one as of now, 5v is connected to the Vdd gnd to gnd, and a jumper between sleep and reset, tried without the jumper and still nothing. The thing is I got a reading for some seconds, but it was 1.2 V which, i think is a bit high.

As of code, i dont run any code, just wanted to test them, I will put them on a cnc shield v3 with GRBL, Tested them there and still no voltage in the terminal, the motors works tho. But only in one direction and I’ve read on the internet it maybe has to do with adjusting the current limit.


The screwy thing is a trimpot. The voltage from the trimpot to ground is the reference voltage for the current limit control. It ranges up to about 1V, but it should not be zero. See:
How To Correctly Set The Motor Current Limit On An A4988 Stepper Motor Driver)

The current needs to be set correctly if the motor is being driven at a voltage higher than it’s rated for. If it’s too low the motor may skip steps, and if it’s too high then the motor could overheat.

Hi Jeff, Alex
I should have looked in the Core shop. Most motor drivers have terminal blocks for motor connection (screwy things). So I assumed this one did too. Apparently this one has not.Sorry "bout that.
Lesson for to-day. Look first.
Cheers Bob

So apparently, I only can read voltages when the stepper cables are connected, not it works, I set it to around 0.8 as my motors are 1.3 A and have 0.1 ohm resistors, so I did 1.1(i heard is better do not push it to the limit) * 8 * 0.1 =0.88 and i put it 0.85-0.88, is that ok?

That should be OK. You can monitor the temperature of the motors during normal use by simply checking how warm they get, but unless they are being worked very heavily then your limit setting of just under the nominal value will be fine. I don’t know why you are only getting a reading with the cables are connected as that should not affect anything, but good to hear you solved it.