A4988 Driver No Output


I’m building a simple circuit to run a stepper motor using an a4988 driver and arduino uno but the stepper motor wont run. I’ve checked using a multimetre and when powered the vmot and gnd pins give no reading, same with the output pins(1a, 1b, 2a, 2b) and the sleep and reset pins. I also checked with a multimetre and the 12v power for the motor is reaching the driver and so is the 5v power from the arduino to the driver. I’ve tried two drivers so far and neither worked so I don’t believe they are the issue. Here is the guide I am following and a picture of my circuit(motor is off screen because it’s mounted but it is the red,yellow,green and grey wires)

I’m at a dead end and the only thing I can think of is that the stepper motor is dead. If anyone has any suggestions it would be highly appreciated. Thanks :slight_smile:


Those two things are inconsistent - VMot is the 12v supply to the motor so if it gives no reading then the 12v power for the motor is not reaching the driver.

If that’s not what you meant then the next step is to use another motor to test. Note that you should not test the driver without a motor connected as the current limiting feature in the driver may get confused. For the same reason, if the motor is dead then the voltage readings on the output pins may be misleading.

1 Like

Hi @Jeff105671

Thanks for your reply

What I meant by the 12v power is reaching the driver is that I unplugged and checked the wires that directly connect to the driver and it was reading 12v but when I plugged them in and measured the voltage on the top of the vmot and gnd pins there was no voltage. Sorry for not being more clear. Even if the driver or motor was dead shouldn’t there still be voltage flowing through those pins? Maybe it’s not connected properly in the bread board?

P.S I don’t have another motor to test with

If the batteries are flat or there is a poor connection it is possible to get a 12v reading when there is no load on the battery and almost no voltage as soon as a load is applied. You should trace the voltage, with the wires connected, from the battery terminals through each point in the wiring to see if the problem is the battery or one of the connections.

Does anything change at all when you connect the batteries? For instance, if the motor turns freely without the battery connected, does it lock up when the battery is connected?

It is unlikely that you can’t use another motor to test with. Every printer or scanner will have a stepper, as well as older equipment such as a fax machine or an old floppy disk drive. You may need to hunt down the back of the garage, at the kerbside rubbish collection or the local junk yard, but they are readily available.

Have used the A4988 Stepper motor driver with both motors linked below. I used a 12VDC plug pack to provide power to the motors. Tested it with just the plug pack, definitely 12VDC on VMOT pin when power connected. (see pic)

Suggest you check the wiring and breadboard connections. If there is 12V on the wire from the battery pack when not connected but no volts on the VMOT pin when connected that would indicate a significant short circuit or an open circuit. You could check the volts on the bread board rail and at the battery pack, if there and not on the VMOT pin then you have an open circuit between the breadboard and the Driver board. With power disconnected you could check the continuity between the rail and the VMOT pin.

Also it not just the 12V you need to be checking; the GND wire from the battery could be open circuit.

The wires you have plugged into the breadboard look quite large. Suggest using something smaller like the link below.

Jim (Core Electronics Customer)

@Jeff105671 @James46717

I got it to work the problem was that the driver wouldn’t stay fully in the breadboard it would pop back up a little bit but if you hold it down the motor runs. Thank you for your help :slight_smile: