Connection issue with Sparkfun LTE catM1/NB-IoT Shield

I keep losing the network connection within 30 seconds of power on/reset. I have followed all the setup instructions as per the Sparkfun info, including running the register operator sketch. I have initial serial confirmation that it is connected to Telstra, and the shield has received some text messages I have sent to it, so long as it is in that initial 30-second window. After ~30 seconds the blue network light goes out and doesn’t recover until reset.
Attached is a serial screenshot confirming the registration just before losing the network. I was first using an Aldi sim card, and I suspected the Aldi/Telstra combo might be causing the issues, but I’ve since connected a Telstra sim and the issue still exists.

Any help will be greatly appreciated!!

1 Like

Hi Matt,

Are you receiving any error messages when the connection fails? Also, have you been able to run any other scripts that run when connected to the same network. I’m curious whether this is a hardware issue, or something in the original script that’s causing it to trip.

1 Like

Hi Bryce,

I’ve only run the sketches that come with the Sparkfun library. The register operator sketch, and send sms. It always drops out roughly 30 seconds after restart, regardless of what sketch I run or which sim is installed. I haven’t seen an error message per se, but it did fail to find an operator once. See screen shot.

Hi Matt,

We’re going to pull one from stock and have a go to see if we can reproduce your issues on the Telstra network. Some of us have Optus Network SIMs too which’ll be handy to compare if we can reproduce the fault.

FYI, in my googling I came across the great Dev guide from Telstra:

Hi Matt,

We couldn’t reproduce it on Telstra using either the telstra.wap or telstra.internet access point names.

If you’ve got a smartphone, can you install the sim card in your phone let it connect and check the signal strength in your area? Note that this board only has a fairly basic ceramic antenna, and you can improve reception by using an external antenna:

On android, you can also try installing cellmapper:

Or there are some similar handy apps for iOS devices:

1 Like

After running the register operator sketch again, this time leaving the MNO field as default, and deleting the APN info for hologram, it connected and stayed connected. Now I have issues with setting some AT commands, but I’ll start a new thread for that. Thank-you for all the info!