Sparkfun lte is not responding

Hi there
I just bought sparkfun lte cat m1/nb board and I am trying to use this arduino uno board.
I gone through the setup and hook these up and upload the code (register network,
Serial passthrough) but Dnt know why red board’s net led is not glowing and also on serial port it is not intializing.
Any help will be appreciated


The red LED indicates power, not network. If it’s not lighting then the module isn’t getting power.

Firstly, check that the PWR_SEL switch is set to Arduino.

If that’s correct, disconnect the Arduino and connect the device to a USB port. The red LED should now light.

  1. Led on red board for power is glowing as I connect 5v and gnd from arduino
  2. Network led is not glowing
  3. Update the code to arduino (serial pass through, register network)
  4. No reponse and still network led is not glowing.

Hope you got what I mean


If the pwr LED is now glowing then you need to look at the other connections to the Arduino. It appears that you have both the hardware and software serial connections - is the Serial switch set to software?

Also, which serial connection are you referring to when you say it is not initializing - the PC connection to the Arduino, or the Arduino serial connection to the LTE? What exact result are you getting that tells you it is not initializing?

You have not wired the SARA-R4 POWER pin to the Arduino, so the library will not be able to toggle it. Have you tried to manually turn the SARA-R4 power on?


Thanks for reply jeff I really appreciate it,
I tried both software and hardware connection because I got code that works on software connection.
And what do mean about wiring sara I thought that’s all connection I do need to make.
Could u please tell me how should I connect arduino and sparkfun lte board and yes when I run open register code it say intializing lte it’s may take 25 secs if it’s off or 5 secs if it’s on
That’s it.


The documentation isn’t clear, but I suspect that hardware connection won’t work while the Arduino is also connected to the PC - the Arduino IDE will take over the hardware port (0,1). So software (8,9) is probably the best option to get up and running.

The Power and Reset buttons of the SARA are wired through to the shield pins. Without that wiring to the Arduino the software can’t do a power-on or a reset. Therefore you would need to manually power on the SARA using the Power button on the module (a reset should not be required). But from your comment it appears that you are using that Power button, so that connection to the Arduino is not required.

Therefore afaict 5v, Gnd, 8 and 9 should be sufficient. ARef is also mentioned, but it appears that it is not functional on the module and should not be connected.

What is the message at the completion of the 25 or 5 secs? That message will give a clue to the reason for the blue LED not lighting - possibilities are:
-SARA-R4 module is not properly configured
-SARA-R4 module is not connected to a SIM card
-SARA-R4 module is not communicating with a cell network


Yes Jeff
After uploading the code and checked on serial port it just say intializing lte
And say if it’s off it will take 25 secs and if it’s on it will take 5 secs
That’s all I waited for 5mins nothing comes up.
So you recon if I connect the arduino board’s 5v and gnd, vin, and gnd and then pin 8 to pin8 and pin 9 to pin 9 .
This is enough to power up sara also?
And yes I am using power from pc to arduino board


This is in 00_Register_Operator, right?

I would recommend adding connections for pins 5 and 6, just in case begin() relies on being able to do a power cycle or reset.

If it just hangs at that point then it does not complete begin() - you should be getting either a connected message or a fail message. You can insert a smattering of
messages in ‘boolean LTE_Shield::begin(…)’ (2 places) and ‘LTE_Shield_error_t LTE_Shield::init(…)’ in the file SparkFun_LTE_Shield_Arduino_Library.cpp in your libraries folder.

The SARA is quoted as requiring about 200mA - well within the capabilities of the UNO.


Hi Jeff
Yep I Tried as said man connect pin5 and 6 but still no reponse stuck at same message as told before.
I am uploading pic of code I m using plz take a look

1 Like

What was the result when you added those debug statements into the library code? How far through the initialization did it get?

Same as before nothing
Stuck at intializing lte
May take 25 secs if it’s off or 5 secs if it’s on
That’s all.
Hey Jeff could u please tell how should I wire arduino with shield and once wiring is done what led should glow before uploading code

Where did you place the first debug statement? If it is at the very start of the begin() function in the library file then if you don’t see that message that tells you that the wrong library is being loaded. Look carefully through the details from the Arduino compile and confirm that the library you downloaded is the one being used.

Based on the comments in the hookup guide (considering that you aren’t using it as a shield) I would recommend connecting Gnd, 5v, IOREF, D5, D6, D8 and D9. Nothing else seems to be used.


Hi Jeff
Just wording what’s purpose of ioref
Because I didn’t not connect this one

IORef is used to provide the reference voltage for the level shifter - it tells the level shifter what a high level digital voltage looks like, so it has to match the logic level of the Arduino (5v in your case). The low level reference is provided by the module.


Ok thanks
I’ll try this because I wasn’t using this ioref
May be this will solve my problem

1 Like

Hey Jeff
No progress bro
It’s still no response here

Hey @Jeff105671 and @KARAN164935

I apologize for not getting back to you here sooner, Jeff is exactly right no network LED nor completion message (or in this case any Serial past the line ‘initializing LTE’) with the correct wiring as I can see from your first image, infers the part is likely faulty. Usually, first point of call for debugging (likely hardware) issues such as this is to grab a multimeter or scope and ensure continuity and that the correct signals are being delivered to the redboard from your Uno and check that there’s no shorts or otherwise damaged components on the board itself although given the errors it is likely a problem with one of the IC.

If you can please send an email replying to your order confirmation email if you have not done so already to let the support staff know about the issue we can get the board sent back so we can verify the issues here and I’ll get a message to the team to identify the faults with the board on this thread so if anyone else is reading this in future they can run through the same steps to identify a fix/error.

P.S. By the way, if you know that the part is faulty and it’s being returned I suggest ordering a new one as early as possible to get the project up and running while the return gets processed

All the best with the project! We’ll be here to help if there’s anything you need.

1 Like

We got this board sent back and made a few repairs to the pins checking continuity against tracers on the board, and it now works correctly to detect and connect to the networks :partying_face: Make sure to let us know if you run into any more issues with it Karan and we’ll see what we can do to help!

Also, for anyone else running into similar issues with these boards, be sure to grab a multimeter or scope and ensure that the voltage supplied to the IOREF pin is correct and has continuity from the pin and onto the chip. Otherwise, the board won’t have a suitable reference voltage to be able to determine the high and low values kicked out by your microcontroller and you’ll get error messages back stating that the LTE failed to initialize.