Creality CR-20 pro over stepping under 2mm

Over the last few days i have started seeing layer separation under 2mm of my prints. Regardless of filament. I moved the head manually to 2.0mm them set step to 0.1 and with each move above i see small movement, but under 2 it moves further. and idea as to a solution.

video of the sound


Hi Lucas,

Thats extremely odd, could you send through some photos of the drive assembly, and the z-stop on your printer along with a video of the machine trying to print the first few layers?
Were you also using Octoprint or another similar service to send G-code?

Stepping into the g-code might let you see some issues, you can use an online G-code viewer or Cura’s built in one. For realtime viewing you can also use pronterface.


Yes I was using octoprint. Also had same issue from sad card. I’ll record a video and post soon. Here is the z drive assembly

Hey Lucas,

What an interesting issue, I haven’t seen that myself on a CR-20 before. Are you using a custom slicing profile? If so, what’re the settings in the profile you’re running with? Also, the filament shouldn’t matter too much here, but are you printing with PET-G, PLA, ABS, or something else? It should help us identify whether there’s anything going wrong with the flow that’s been set or printing speed at a given temp for the first few layers.

1 Like

using PLA, had no trouble with the fillament, had printer since august. i have tried slowing down speed, heating up both bed to help stick and end to see if it were cooling too fast. recording a print now, stand by. thanks for the help so far.

1 Like

here is the video its the full length (28min) but its only until the issue passes of interest

1 Like

Hope the video clear enough

Hi Lucas,

That’s definitely weird! Which slicer are you using? I usually inspect the paths generated in my slicer to see if there’s any condition change at that height, like cooling fan, extrusion width, layer height or similar. at a glance, it almost seems like those first few layers are too high for some reason. It also looks vaguely like underextrusion or a lack of cooling. My printer is very different, but I run fan from layer 2 onwards.

Are you using Z-Hop? (called Lift Z sometimes). Creality printers don’t have the best track record at raising and lowering Z consistently, so turning that off can help.

I’d move your z-axis up slowly with a finger on the gantry to see whether it’s doing it smoothly or not.

You can also let the filament run between your fingers to see if the extruder is pulling like it should.

I’d also get a reeeeeally close look at it printing, as you can usually spot what’s going on better while it’s actually happening

Keen to get to the bottom of this mystery!

1 Like

Thanks for all replies. I use the latest cura slicer. But my partner said have you tried a reset. So ran m203 to clear back to factory and so far all is good

let’s hope it stays that way.

1 Like