Core Electronics Forum

Trouble with cr-10s pro v2

Hi I’ve got a cr10-s pro v2. I’ve just assembled it and started it up… when I attempt to calibrate it and level it the nozzle gets pushed into the bed. It has a bltouch sensor that seems to be the issue and as it does the two probes and comes back up on the third descent it plunges hard into the bed… and tries to keep going. Help!!

Hey Kian,

3D printers can be scary when they don’t do what you expect.

Let me see if I can help. The first point of call is a hard reset and updating all the firmware.

If that is all good it could be a problem with the capacitive probe that it uses for auto leveling. These react with the temperature and moisture in the air so take the time to check it is all dry, looks okay and is plugged in.

Also check that the bltouch sensor is extending out like what is happening in this video (https://www.youtube.com/watch?v=l4dZXzpXEpc)

Another thing it could be, make sure auto leveling it is turned on in the software in the leveling mode menu on the display.

Hope this has helped and keep me posted on your progress.

Kind regards,

Tim

2 Likes

Hi Tim

Thanks so much for your help. Ok… the probe acts like it does in the video except on the third descent with probe up the nozzle just keeps going and grinds into the bed.

How do I do a hard reset and firmware update? I have a Mac laptop and it doesn’t look like it connects to the unit. Sorry to be a difficult case… but I’m really stuck here.

I’m very tech and mechanic minded… and know my way around computers well but total new to 3d printing.

Any advice and tech supper would
Be warmly appreciated

Thank
You

Kian

1 Like

The probe lights up and stops on contact for two times during leveling… and then disregards the height and crashed into platform. What could that be?

Heyya,

Lets go down the firmware route first. For your printer the Cr-10s Pro V2 the firmware is here. https://www.creality3dofficial.com/pages/firmware-download

It takes a couple of steps to put the firmware into the machine. This is a guide for Cr-10s Pro, follow through the steps but use the above firmware for your version 2. https://www.youtube.com/watch?v=SBX30GmM3Qo

If that does not work there must be some interruption between the probe telling the machine where the build platform is and what the machine records it as.

Kind regards,

Tim

(PS, here is a video of someone whose downloaded the firmware and is using a macintosh, I’m sure your mac will not be a hindrance in this regard https://www.youtube.com/watch?v=q_hVsF7qPkk)

2 Likes

(3D printing with a new printer is always a bit of a journey to set up but I hope your staying motivated)

1 Like

(An alternative method to update firmware that should work for your Pro V2 here https://www.youtube.com/watch?v=17BmvUSKntE) (Also this https://www.youtube.com/watch?v=y_DwrgnVses)

Tim, you’re a legend. thank you. I was feeling pretty anxious when I opened the box this morning knowing there would be issues… and a steep learning curve. I wasn’t disappointed! hah. I will update the firmware and get all that done and let you know how I go, I am still motivated just a bit disheartened as the nozzle dug a hole in my bed and some good scrapes on it too. I’ll worry about that after I get it working! I was going to update using Cura on my Mac… good plan ? I’ll be in the laboratory later to give it all a go, I’ve got the files and apps ready to rock…

thank you so much for your help in this… creality isn’t being much help… fingers crossed we’re printing tonight!!

cheers

1 Like

do you recommend the Tiny Machines firmware or Creality firmware with the Bltouch?

Hey mate,

Would definitely recommend doing it through Ultimaker Cura and would steer you towards the Creality firmware. Keep me posted, hoping to hear of future success!

Roger that. I think I know what may have triggered all this… when I set it up this morning in my haste I did not attached the smaller wire for the Bltouch along with the larger ribbon wire. I tried to level it like that until I realised what I had done… turned it off, attached wire and then the probe worked BUT I think that may have completely thrown the Z axis out of whack and lead me to where I am now… does that sound like it could be the case? either way I am updating the firmware… just trying to see where I went wrong… :slight_smile:

1 Like

In that case (although I am sure the firmware will do this as well) look for a “Probe Z Offset” setting on the LCD menu or something similar. If it’s enabled in the firmware, it could have been altered when you first turned it on.
Punch in a setting of around 0.2 and then make sure to ‘STORE’ the settings. If not give that probe a proper thrice over.

1 Like

awesome! I let you know!

UPDATE: firmware and LCD update did nothing… however I ran the reset Gcode and voila… fixed!

just lining up my first print now… wish me luck! hah… my bed is f*cked though… had to order a new one… I’ll let you know if it prints… thanks for all your help!!

3 Likes

first print is working… hah! TIm… thanks man… you’re a lifesaver with all your help today!! cheers!!

6 Likes

Very happy to hear! Hope all your future prints turn out perfect and if not there’s some swell 3D printing guides on our website.

Have fun and kind regards,

Tim

3 Likes

Hello, i am having the same issues stated above, what file did you use for the reset gcode?

1 Like

Hey Kurtis,

Welcome to the forum!!

Usually you can inject G-Code into the printer using a USB cable and a program by the name of Pronterface. I couldnt track down the exact command in the video but suspect it is M502, Factory Reset | Marlin Firmware is a good refernce for other g-code commands and the usage.

Liam.

1 Like

kurtis, send me an email and I will send it to you. Kian at Authentink dot com

1 Like