Ethernet to serial converter possibly DOA

I received an Ethernet to serial converter in the post yesterday along with a rs232 to ttl adapter.
I power up the eth to serial converter today with a 5v plugpack and plugged it into a switch.
No link lights or anything came up on the switch port.

I then realized the product was POE capable.
The product by the way came with absolutely no documentation.
My fear is I may have killed it by powering with 5v pluckpack and also plugging into a POE switch.
I would however think that it should be protected against that.

The configuration program that I downloaded has searched for it on the network and cannot find it.

Alas, this is one of those moments which is why a lot of people buy two of everything for DIY electronics!

It’s going to be hard to half split if this is a software (config / be it the module or your PC) or hardware issue (some fault on the module). We’ll power one up and see what happens (been a while since we’ve used one of these).

I just wanted to test this ethernet to serial converter.
We currently using 1 from jaycar however this is much cheaper.


Hey Lloyd which of these 2 screens are you getting from the config tool?

well it looks more like the second one but there is no data in any of the fields

1 Like

Okay. The only power indication I am getting (when powered with 5v plugpack) is that the green/orange lights switch on. Could you clarify for me if they are switched on or off.

I cannot see any lights on the board itself.
I could also not see link light on switch it was plugged into.

Hi Lloyd,

If you are not getting 2x status LEDs on the WIZnet module ethernet connector then it’s unlikely the board is powered. Either the power source is not connected properly, can’t supply enough current, or something has gone wrong on the module.

The 2.1mm plug should be wired up with the positive pin in the middle. If you are concerned about a PoE power conflict then you can easily disable PoE on the other device - it’s often disabled by default for safety reasons.

Hi Graham
I have just tried again using 5v and not poe switch
I am seeing network lights on now.

Config tool still cannot find it though

Do they have a default ip address or are they set for dhcp?

Thanks Lloyd, which of the two screens are you seeing from Aidans post?

1 Like

Thanks Llyod, Aiden left the warehouse a while ago and will be back in the morning. This will certainly help as that’s the same screen we were getting. Will post the way forward by tomorrow (I wasn’t there for the fix).

The summary is

POE switch only no lights.
5v plus plugged into switch I see both lights near the network port.

The config tool cannot find it, either on a switch or directly on my laptops ethernet port.
I have connected it to a switch with DHCP but it never asks for an address.
The on-line documentation shows no default ip address.

Conclusion is:
It’s dead Jim.


I am out of the office all day tomorrow.
I need to get this resolved or I will just go to Jaycar and buy one.
I would prefer to use this one as it only needs 5v power supply.
Looks like it will be late next week before I get a working one if I don’t go to Jaycar.


Hey Lloyd, after getting this screen I was able to hit the search button at the bottom of the screen and the MAC address appeared in the left hand “Boards” menu. You then can connect to the board after selecting it. Once you connect all the fields will update to reflect the change. My Network settings on my PC showed I was connected to a Unidentified network whilst connected to the module, perhaps check that is the case before trying the above?

It searches but finds nothing.


Could you try doing the search with DHCP enabled as the IP config method in the config tool?

I’ve tried all things.
I am pretty sure it’s dead Jim.
I am not back in the office till Monday.
This is why I wanted to speak to someone on the phone. Going backwards and
forwards on this forum was a waste of my time.
I had already tried all your suggestions before I rang you.


Hi Llyod. Thanks for your time - the forum is certainly the best place to have a tech conversation and we’re here to help.

With that said, lets get this product back and we’ll take a look. Either way we’ll look after you. Hit reply on your order confirmation email and link to this forum topic so we can get the ball rolling