Functionality Issues - Waveshare 4G HAT for Raspberry Pi (LTE Cat-4/4G/3G/2G/GNSS)

Hi there,

I’m also having trouble with connecting the Waveshare 4G HAT to my Raspberry Pi 4B. I’ve noticed others are having issues too, so my apologies if this is a bit of a repeat.

I’m an absolute newbie when it comes to using Raspberry Pi’s and Linux operating systems, so this is kind of like teaching a toddler to walk for the first time…

The 4G HAT does work on my laptop via Windows; but then connecting to my Raspberry Pi 4B, it sees it, but doesn’t let me connect to the internet.

I tried reading the SIM7600E-H 4G HAT wiki guide from Waveshare, but the English translation from Chinese, and my newbie understanding of Linux made things incredibly difficult. I only got as far as completing the testing via Windows, but when it came to the instructions for Raspberry Pi, I got absolutely lost.

I also saw the following guides; “Raspberry Pi RNDIS dial-up Internet access”, “NDIS dial-up and self-starting”, and “PPPD dial-up”, but am not sure which ones I’m meant to follow, or if I’m meant to follow all 3.

Plus, down below the main guide, there’s a section called “Raspberry Pi Initialization Settings”. I tried following the instructions but it came up with an error when entering the first command line.

If anyone with a huge amount of patience, and who can interpret Waveshare’s wiki guide, is willing to help, that would be amazing!!
I’m also using a Telstra (Prepaid) SIM card if this helps?


Did you check this English wiki page?

1 Like

Hi @lia262073 yeah I did, and I found the translation quite difficult to follow :frowning:

Hi MattyPatti.
Same issue here… There seems to be some instructions missing to finalise the config to allow the SIM7600G-H to be able to provide an internet connection.
I am sure that the missing steps are obvious to some but even installing the demo and then copying to a different location is far from well documented.
The need to change folder permissions etc to achieve the install and relocation is not mentioned. ARRGGHHHHH!!!
Can someone please fill in the missing pieces of the puzzle!
One of the ‘solutions’ that exist in the Wiki refers to /dev/ttyUSB*
Unfortunately I do not have any ‘ttyUSB’ entries, plenty of others.,ergo another commissioning document that just doesnt and can not work!

1 Like

Hey Matty,

You mentioned you receive an error when you run the first command line input from the “Raspberry Pi Initialization Settings”. What error message are you receiving?

As far as I’m aware you have the right guide and section located for getting this up and running. Hopefully we can help trouble shoot you through those steps.

@Kym252504 did you have any luck working through the “Raspberry Pi Initalization Settings section”?

Hey @mattyjpati - you might want to take a read of @Kym252504’s findings here. It’s a long thread, but it came down to something simple in the end (as it usually does :sweat_smile: )