Help with my flashforge Inventor 2

Hi, I have been a happy user of a Flashforge Inventor 2 for almost 5 years, but last week something went wrong. It looks as if the stepper motor which feeds the printing filament into the hot end has died. Everything else on the printer seems to be okay, but filament won’t feed through the hot end on its own. I can easily push it through (no resistance from the motor) and I can also pull the printing filament out (once again, no resistance from the motor).
I have removed the motor and tried to find a replacement - the only information on the stepper motor was “Bohong stepping motor, 42hb40f08ab-06” and a date (2018.01.31).
I have specifically looked for a listed replacement using “Flashforge Inventor 2” as part of my search criteria, but have not had much luck. I am now seeking alternative sources for the same Stepping motor - has anybody had this to replace the stepper motor on a Flashforge inventor 2, or have any suggestions?


Hi David.
I have a flashforge printer, not the same model as yours, and I had an issue a couple of years ago with the extruders where they would not feed filament.
It ended up being a broken wire in the stepper motor wires.
I replaced the 4 core wire all the way from the extruder to the motherboard and it worked fine after that.

While I have had steppers die on CNC machines, I’d be surprised if the actual stepper was to blame, unless you have already changed out the cable.


That looks like a 40mm 0.8A version of this range:

The additional designation is likely to be things like shaft diameter and connector type - may be able to deduce what the ab means from the specs for the 42HB40F107AB.

A manufacturer is unlikely to diverge very much from the ‘standard’ types. If you can match the physical dimensions to those details then you have enough information to find an alternative supplier.

But I would strongly recommend testing the motor first - a failure elsewhere in the system, such as controller (hardware or software) or cabling is much more likely than the motor.


Hi Andrew
The enclosure which houses the printing head is connected via a flat ribbon (unlike our other 3 Flashforge printers which are as you described). I de-soldered the connecting cables from the driver board/shield and replaced the connecting wires and clip, and tried it again. Alas, no improvement. It did give me hope for a short time… Thanks for the share and idea.

Bugger, that would have been the easy fix :frowning:

1 Like