Artillery Sidewinder X1

Hi I just upgraded from stock firmware to marlin and this TFT firmware GitHub - pinguinpfleger/ASWX1-TFTFW-MOD: Artillery Sidewinder X1 TFT Firmware Mod I’ve also calibrated e - steps x y and z axis stepper motors and I’ve been tweaking some adjustments in ideamaker etc. but i am struggling from really bad tolerances and i don’t know hot to fix it, I’ve printed some tolerance tests and i didn’t even manage to get the 0.5mm tolerance for some reason. it also stops at the same spot partway through a print and just sits there and makes a big blob around the nozzle. ive attached a zip with my ideamaker profiles if it helps

Artillery Sidewinder (20.1 KB)


Hey Sebastian, welcome to the forums!

Artillery printers are a bit of a rarer breed and that specific firmware upgrade is even nicher so I don’t know if anyone here has experience in that area.

That said though, 0.5 mm is definitely something wrong. I would start by rolling back all your changes and testing it bit by bit to see what’s at fault. My first bet would be a slicer issue so maybe roll back your slicer settings to defaults and give it a go. Stopping on the same spot everytime sounds like some slicer config issue.

If that doesn’t fix it, maybe give the old firmware a go and try to revert the machine back to “factory setttings” as much as possible. If software and firmware wise it’s at a point where it worked previously and it’s still not working then you know it’s a hardware fault.

Sorry I couldn’t be more specific, I don’t have much experience with artillery printers, I can only offer to break it down and check section by section.

Best of luck and keep us updated!


Hi Sebastian, Welcome to the forum!

On top of what Jaryd has mentioned, I’m thinking that being that it stops at the exact same place every time it could be some sort of short, check for any play in the motor connectors and also see if any wires are being pinched anywhere.


Its probably not a short, as when i say stops at same spot each time, its not all the time. sometimes it works, and if it was a short would it turn off the printer?

Do you know what the “Default” slicer settings would be? i don’t really have an actual base slicer settings. also for a long time i have been experiencing really bad elephants foot, that may have something to do with it. i might print a Cali cube to see if the stepper motors and extruder are actually calibrated or if i possibly messed it up while calibrating it. ill keep you posted!

Marlin definitely supports short detection, generally if one is detected you will get a message on the screen that says “Print Halted”.

For the slicer settings easiest way to get the defaults would be to add a second machine exactly the same as your first. Alternatively you could look at using another slicer Cura/Prusaslicer/Orca to see if you get the same issue.


do you know of any links to any profiles?

I’ve attached the photos of the settings i think are relevant if there are any settings you need just ask me and ill get photos of them :slight_smile:

Hey Sebastian,

Has this printer worked fine previously?

And when I think it may be a slicer issue, I think it may be how the slicer is set up for the printer, not the print settings. To eliminate any slicer settings try and install Cura, it has an inbuilt default setting for the x1. Just do a test print and slice it in Cura to eliminate any weird slicer issues.


Previously it wouldn’t stop partway through, and i got it down to 0.4mm tolerance although that’s not good, ill install cura and try what you said and tell you how it goes


I downloaded cura and used default slicing settings, i sliced a print but when i started it what would happen is that the temp would stay where it currently was and not heat up at all it would just stay the same.

1 Like

This is running into an area of needing specific knowledge about the printer and that firmware. We may be either slicing incorrectly for this specific flavour of firmware or have firmware issues. The only thing from here I can recommend is to roll it back to the default and see if the issue persists.