How to add Addons to Kodi Media Center

Aidan just shared a new tutorial: "How to add Addons to Kodi Media Center"

If you have built yourself a home media center using a Raspberry Pi, you’re one step ahead of most people out there. The pure joy that comes from having a dedicated media center is something no Smart-TV can accomplish. And now, transporting all your …

Read more

1 Like

I have just brought the pi 3 medias center

I have install it correctly

But when Ii go to add the add ons I follow the instructions to kodi add on repository it wont load any

I have Internet connection

Hi Brendan, thanks for the post.

From anywhere in the Add-ons menu, press left arrow to access the tabbed menu that hides on the left side of the screen. From there, select the check for updates option.

What follows is a bunch of processing and maybe a prompt to remove incompatible packages. After that’s complete you should be able to follow through with the rest of the tutorial.

– Michael

1 Like

Hey Michael

Still no good did the update no prompts went to check repository again still nothing is showing up I double checked Internet all ok everything seems to be correct

Hey Brendan,
I followed the tutorial with the same version of OpenELEC as is shipped out with our kit, and found the same problem you did. Updating fixed it for me though. Did you return to the “top-level” of the options? (By selecting the " " option at the top of each menu).

Otherwise, it might be best to start right from the start.

On Windows, you can download the most up-to-date version of OpenELEC from here and flash it onto your SD card using Win32 Disk Imager. Note: you may have to clean your SD card first, before flashing the disk image onto it.

1 Like

Just a thought!

Before you proceed too far, check your timezone settings, and that your time is as correct as possible. Many servers reject requests coming from devices too far out of sync. This goes for the date also.

System > Appearance > International

Settings are:

  • Region
  • Timezone Country
  • Timezone
1 Like

Will try flashing my SD card

Cheers for the help will post if successful

Hey Michael sorry for the slow reply

the link for the update didn’t work can you please send a new link so I can update

Hey, @Brendan32821.
It was just a jump-link to the Raspberry Pi section of OpenElec’s downloads page. Not sure why it broke.

Hi @Brendan32821,
I seem to be having the same issues with the media kit shipped fron here. Did you end up having to reload everything?

Hi Michael,

I am having exactly the same issue as the guys above. I have just bought a new media kit from you. Connected it up and updated it over the Internet, but it will not let me add any add ons. It just gives me a failed to install error message on any install I try.

Any suggestions?


Hi Wade & Dave,

There was an issue with a recent version of OpenElec that affected people around the world (and caught us out with a handful of customers). Updating it doesn’t appear to fix the issue. It would be best to download the latest image and write it to your card.

  • Download the latest image here (scroll to the bottom, download the Raspberry Pi 3.
    Important; use the Pi 2 + Pi 3, not the first generation one). Which at the time of writing, is titled [Stable] OpenELEC 8.0.4 (arm) Disk image

  • Follow the 4 install steps on this page

1 Like

Thanks Graham for a prompt reply on a public holiday. The new image seems to have sorted out my memory writing problems.