Kodi Add-on repository error "Could not connect to repository."

New to Raspberry Pi.
Just purchased Raspberrt Pi 3 Media Centre Kit from here. Straight out of the box and following tutorial for add-ons,
Have Internet connection but I receive this error “Could not connect to repository”.

Please help.

Hi Wade,
Which addon were you trying to install? It could be that it’s not compatible with the current version of Kodi, or that the repository is offline.

Hi Sam, are you the Sam I spoke to this morning?
I literally went to the first step of clicking to add something from the Kodi Repository from the tutorial… anything… but it was not connecting to the library at all so could not progress any further in the tutorial of how to use add-ons.
Exploring the menus I just went through and found how to do a hard reset of OpenElec, Just completed that now and the only difference this time was during the original setup I remember when entering the network password at home the first time a brief error popped up something like “did not receive a reply”. But it showed status as active anyhow so I was always assuming the connection was good. Also I was prompted that Updates were available so assumed the Internet Connection was good as how would it know if an update was available if not connected to the Internet.
Anyway this time I got the same message but tried testing it again and no error about “no reply” popped up. Continuing on with the Tutorial now and I can now connect to the Kodi Add-on Library. :thumbsup:

Hi Wade,
Yep, same Sam :slight_smile:
Glad to hear it got sorted out, a reset was going to be my next suggestion. Let us know how you go.

Straight on continuing with the tutorial… found youtube… download bar progresses very quickly to 20% and then bombs. A message appears to say “Installation Failed”. I’ve tried this even with just a skin… Confluence… and again, “Installation Failed”.

Please help… What am I doing wrong? This is straight out of the box.


Hi Wade,
I’m not sure what could be causing that sorry, as it’s worked fine when testing. My only other thought could be an internet connection issue, are you using Ethernet or WiFi?

Hi @Sam,
I’ve tried both. Both say working fine.
When I get home I’ll look into the time/location. If that fails will look into reinstalling from scratch.

Hi @Wade40057,
I’m encountering similar issues to you.
I believe the issue is due to a lack of storage space on the micro SD card,
although a 16 GB was supplied with the kit, the OS isn’t registering the full 16 GB.
But what looks to be closer to around 1 GB.

Can you please confirm this Hypothesis by checking your storage space by going to;
Settings -> System Information -> Storage

Hopefully this isolates the fault so @Sam can help resolve this issue.


P.S. From what I understand of the issue (Not Much), is has something to do with the drive partitioning
that the OpenELEC software does on its first boot up.

P.P.S. My storage stats say something like; (Raspberry only using items in the Media centre kit, nothing extra)

Filesystem | Size | Used | Available | Use% | Mounted on |
/dev/mmcblk0p1 | 577.1M | 147.5M | 364.3M | 29% | /flash |
/dev/mmcblk0p2 | 27.0M | 26.3M | 0 | 100% | /storage |

P.P.P.S I’ve attempted to update it, and it won’t let me (manually dropping the file into the update folder doesn’t work either as computer says there’s not enough storage space).

P.P.P.P.S. Final thing I’ve tried the SSH PuTTY console and tried:
touch /storage/.please_resize_me
Which didn’t work.

Sorry for the long message,

Thanks Again

One more thing,
I’ve purchase two of the media centre raspberry pi kits and they are both doing the exact same thing.

Hi @Sam,
Is it possible that the latest batch of the micro SD cards with OpenELEC were incorrectly partitioned?

  • Adam.

Hi @Adam39407,
I believe you are correct. I kind of guessed the memory was the problem but originally thought it was a dodgy card due to the displayed file size… @Sam assured me that it was ok due to the way Raspberry Pi utilised the memory or something. After countless hours playing with different options, googling and searching these forums with still no clear solution I simply re-imaged the card myself. Being a first time Raspberry Pi user, I thought this would be a complicated task but to anyone else out there purchasing a media kit if you experience any problems whatsoever when first setting up Kodi I highly recommend this option as a 1st resort as it is quite basic.

Using my Laptop with Windows 10 I simply:
*Installed Win 32 Disk Manager
*Downloaded the latest version of OpenElec for Raspberry Pi
*Unzipped it using 7Zip
*Opened the Disk Manager and located the downloaded image of OpenElec, and WRITE to the intended SD card.
*Inserted the card back into the Raspberry Pi and Presto… all is good.

I went straight back to the memory stats and /storage now reads in the Gigs.
I then proceeded to the original Add-ons tutorial and installed Youtube to start and everything went sweet.

For Imaging from Linux or MacOSX instructions can be found here on Wiki.

For any beginners out there this literally takes minutes.

Let me know how you get on @Adam39407.

As a side note, re-imaging was suggested on another post due to similar issues but it was not clear if the problem was resolved so I hope this post helps others.



Hi @Wade40057,

Thanks for this solution, its fixed my problems as well.

  • Adam.
1 Like

Hi Guys, I’ve just jumped on a fresh image and it does appear not like the default image. I’m looking into causes for that as we speak and we’ll have our images for the Media kit sorted out, but for now, reflashing the SD card does the trick. Thanks for bearing with us through this.

1 Like

Hi @Wade40057,
I’ve updated our SD card writers with the latest version (8.0.3). I can boot a preflashed OpenELEC card (the same that a customer would receive) and install the Youtube add-on.

Going into System info > Storage I can see two partitions on the card:
/dev/mmcblk0p1 at ~500MB mounted on /flash
/de/mmcblk0p1 at 13.9GB mounted on /storage

So everything seems to be in order here. It seems that perhaps this was a release issue? The previous version we were shipping was 8.0.0. @Sam mentioned he was able to replicate the problems described in this thread on a card running 8.0.0, but upgrading to 8.0.3 seems to have done the trick.

1 Like