Kodi media centre loading issue

I am having trouble loading the media centre on my Pi 3. I have installed the disk image from the Openelec website. The first time I started the Pi3 it ran through the normal startup with the Openelec logo page and commands scrolling down the lefthand side but then it just goes to blackscreen. anyone else had this issue?..and solved it?

Cheers in advance

Hi Eli,

Just so we’re on the same page - can you link / confirm the Kodi build you are using?

Raspberry Pi 2 and Pi3 [Model B+ 512MB] - Diskimage

That’s the one - we use it a few times a week! @Sam is the go-to around these ways for Kodi, lets see what he says

1 Like

Hey Eli,
Have you tried flashing the openELEC image to a different SD card?

Hi Eli,

Assuming that you’re running with a fresh image of OpenELEC, there are a few things you can do to check that it’s been imaged correctly. Plug your SD card into your computer and open the command prompt (in the start menu, type “cmd” without quotes, and launch cmd.exe). In cmd, type in the following command (replace D with whatever the drive letter of your SD card is) and post a screen shot of the results here:

chkdsk /R D:

Then in cmd, type in (again, replace D with your drive), and post the screen shots:

dir D:

This will tell us if there is anything wrong with the basic OpenELEC image.

Will do that tonight
Cheers Sam

Not a problem Eli, hope we can get it sorted out!

I tried a different sd card and it loaded first pop.I then re-formatted the supplied sd and burned a new openelec image and then it worked as well. It may have been human error on my part or a prob with my image writing software. Either way we are up and rolling nicely now.
thanks for the assistance.


Glad to hear that it worked out Eli. Sometimes it can be so easy to overlook something. Have fun with your Raspberry Pi!