Incorrect keyboard entry


After setting up the keyboard for a Logitech US version and testing the text everything works fine. When I type " m" it appears as " m"

However in the console window when I type " m" it appears as " n"
Trying to type " mkdir" appears as " nkdir" so reads error

Please help with some feedback

cheers Ian

1 Like

Hi Ian

In the console window try running the command:
setxkbmap -layout us
Though the fact this is only an issue in the console is a little weird.

hi Clinton…

Thanks for the reply

If you notice there is an m in the command line

So it reads setxkbnap -layout us and will not execute

Any further help would be appreciated… I’ve tried three different keyboards and formatted the Sandisk card with a new Noobs

cheers Ian

1 Like

Hey Ian,
So that we can try to replicate this issue, have you done anything else to your OS since booting into Raspbian for the first time? Changed any settings, etc?

hi Aidan…

I have increased the size of the font in the console as shown in your video and changed the third keyboard to US

1 Like

Thanks for that Ian, if you change the font size back to regular (or reflash your NOOBs card and refrain from changing it) do you get the same m/n key swap issue?

Hi Ian,

You need to change your keyboard settings to be the proper layout as Clinton recommended. The default is GB and you need US. US-international is different still and will may different buttons.

In fact, you have to do this twice - once for the console and once for the GUI. This is why you are only having a problem in the terminal.

If you change it by editing /etc/default/keyboard

To edit the mapping, you have to change it in the /etc/default/keyboard config file.Use sudo to obtain temporary write permissions on the file.

sudo nano /etc/default/keyboard

Change the XKBLAYOUT=“gb” to whatever type you need. Mine was XKBLAYOUT=“us”.

The “m” key will be there somewhere, you just will need to poke around to find it. Also, you will need to reboot once the changes are made or they won’t take effect in both the GUI and the Terminal.

If you need to try some other options there are a bunch to try here:

Hope this helps!

hi Stephen…

Problem resolved

I re-flashed the sandisk with noobs and did not change the font to SANS which I did before

I have resized the existing font and all is running fine

many thanks Ian


hi again…

Please can you add a second email address for me

I use and redirect because it is shorter

When I reply to you from my Outlook account it does not recognise me

cheers Ian

1 Like