Infinity Kit problem getting it to work

I have assembled the Infinity Kit checked and checked to make sure correct, however the Kit keeps pulsing the green lamp, and when I load the default programme it tells me the kit is ready but still keeps pulsing the green led. I have constructed many kits in my 83 years, but none so frustrating as this one. Is it me or have I just got a lemon.


I’m sorry to hear that you’re having issues with your kit. Just to clarify a couple of things, when you say that you’re loading the default program, what exactly is the process that you’re following for that? The Photons all come with the default code pre-flashed onto them.

I’m assuming you’re using the online IDE and when you say ‘the kit is ready’ you get a post compilation message after you’ve tried to flash it?


We do cover off on how to claim and reflash the Particle Photon here (inside “Tutorial 1”)

Which has these steps:

  1. Plug in your Infinity Kit and rotate the knob all the way to the left (OFF). Press the SETUP button briefly. Your Photon’s status LED should start blinking blue – it’s now in listening mode, waiting for your input to connect to Wi-Fi.

  2. On your phone, download and open the Particle app. Create a Particle account (or log in if you have one already) and follow the prompts to add a device to your account.

  3. During this process you’ll provide Wi-Fi credentials to your Photon, allowing it to connect to the internet. You can also give your Photon a name. I find it helpful to use names related to the project, so “InfinityKit” works for me.

  4. Once your Photon has been successfully claimed, briefly pressing the SETUP button will cause your Photon to connect to WiFi - it will flash green then breathe cyan once connected.

  5. Navigate to and log in with your Particle account, then open the IDE. You will be greeted with a blank Particle App.

Reading in between the lines, you were able to do the above steps with no issues. LED status is working as intended, etc. Now you’ve continued on with the “Setting up a Project”. Assuming so, you are seeing “A breathing, cyan dot next to your Photon’s name indicates it is connected” before doing anything else?

1 Like

Hi Sam,
I have done everything according to the Tutorial with setting up, and have the programme indicating that the InfinityKit is pulsing the cyan dot, and tells me it’s “ready”. However the Kit will not run. I noticed in the Tutorial, Graham says to make sure to hit the * icon. This does not show up in my programme. Then the thought occurred to me if the computer Graham used in the Tutorial was running “Windows 7” this would account for the difference. I have two computers, both running “Windows 10 Pro”. I have had trouble like this in the past when I tried to programme my Gimbals for my Multi Rotor machines, and found I had to go to a friends computer running “Windows 7” for it to work. The difference between the two systems is like “chalk and cheese”, to coin a phrase.

I originally had “Windows 7” but then bought and installed “Windows 8” some time back. Eventually Microsoft upgraded me to “Windows 8.1” and eventually to the current “Windows 10 Pro” at no cost to me. I have had no problems using this operating system, as I have had AVG Anti-Virus and AVG PC TuneUp for years, have had no viruses, and using Windows Live Mail all the Spams get attended to. It sometimes shows as having received 10 emails, but showing on the screen are only two. This is because all the unwanted nuisance emails have been blocked, also their Domains too. I find a lot of the nuisance emails come from Greece and Portugal, however there are some coming from within Australia now, some stupid citizens of this country being influenced by Indian hackers. Not only do the senders have to be blocked, but their Domains too.

My daughter and her husband run an accounting business here in Port Macquarie, and they have a couple of computers running “Windows 7” as the Taxation Department is still running “Windows 7” and their “Windows 10 Pro” computers are not compatible. Once again the Government is way behind the rest of the World, however Donald Trump is changing this in the USA, however it will take our Government years to catch up.

This reminds me of the “Good Old Days’’ when we had Beta and VHS for video tapes. Then we have all the different operating systems in the World with television, such as PAL and NTSC and others. Then they had to confuse the issue with DVDs and Regions, us having Region 4 and the list goes on and on.

Isn’t it any wonder a lot of older folk have trouble using their Television Remote Controls, let alone using Mobile camera phones, and computers. I thank the Lord I have kept up with all the latest, and have no problems with them, even though I’m now 83 years old. I have been flying radio controlled models since 1963 and at present have seven (7) multi rotors or “Drones” as most people refer to them. I consider I fly them extremely well, and have taught dozens of people to fly too. I have video cameras fitted to a couple of them, complete with Gimbals, and one has a release mechanism for releasing parachutes and chuck gliders which I designed and built myself. I repair my drones from parts I purchase from China, and have a good understanding with many Chinese companies. Quite a few offer me great discounts, as I am considered a Platinum customer. One Multi Rotor sent from China and valued at $400 was stolen in Australia Post, and the Chinese Company replaced it with another, at no cost to me. They really bend over backwards to get our trading.

I have always had an interest in Electronics since I was fourteen (14) years of age, and built dozens of kits in that time. My “Playmaster” Amplifier I use in the home, was built from a kit in 1980 along with a Graphic Equalizer, and is still performing very well. It uses Mosfet Transistors, and sometimes rattles the doors and windows of the home, when I turn up the volume. I made a modification to the kit, and it was acknowledged, and published by the Magazine of the day “Electronics Australia”. Many people thanked me through the magazine for the modification. I have lots of other kits constructed many years ago, all still running well. I build my own computers, and also look after the computers of a couple of friends. Hope this gives you an insight into my History.

David Whitehouse. IHS.

Hi David,

It’s a bit strange that your IDE window is showing your device as being ready, but the board is breathing green. A bit of info on the LED colour status is that green is the colour used for network connectivity and cyan is Particle Cloud connectivity. So when the LED is breathing green it means that it’s connected to your WiFi network, but not the Particle Cloud. I’d say that the best way to resolve this issue would be to go over Tutorial 1 again and reclaim your Photon. Completely set it up from scratch and go through the claiming process again using either a mobile device or the Command Line Interface on your computer (let me know if you’d like some pointers on this as it can be a bit tricky to setup for the first time).

Once you’ve done that, you’ll need to reflash it with the Infinity Mirror code which is featured in Tutorial 1 as the claiming process overwrites any code with the default Tinker program.

Hi Sam,
Thanks for the information, however I’ve tried it many times, and it works out the same way every time. The Photon keeps pulsing the cyan LED and tells me it’s ready. Maybe the processor has become corrupted, so if you can give me some pointers on how to fix that, by all means please do.


Hi David,

As Sam mentioned, the unusual part about this is the status of the LED vs what you see in the IDE. Particle Photon’s have been around for a while and have proven themselves to be very stable. To the point where you have two seasoned makers stumped with how this can even be happening!

For the IDE to depict the device is “Connected”, however, physically the Photon LED shows “just connected to WiFi (not Particle Cloud)” is highly unusual. If you feel you’ve done everything you can, then send a message to to begin the RTS process for the Photon. From there, we’ll give it a go, step by step, and report back the outcome.

Hi Graham,
Thanks for the advice about the Mirror Kit. Is it possible for me to send the Photon back to you, so you can check it out. I would be prepared to do this, because like yourself, I imagine you and I would not let anything like this stump us. I am prepared to meet the cost of postage both ways, and any time spent in solving this dilemma. If not, I would be prepared to pay for another programmed Photon to replace it, including postage. I await your advice in this matter.

David . . .

Hi David,

Sure, send a message to and lets get this RTS underway!

Hi David,

I’ve had your Infinity Mirror kit on my desk this morning to take a look for you. When I powered it on, it displayed the issues you mentioned where it was breathing green (although as it wasn’t connected to you WiFi network, it was blinking green). As discussed previously, that means it’s connected to Wi-Fi but not the Particle cloud which is indicative of a coding error which is blocking the call to connect to the cloud.
I started from scratch, following Michael’s tutorial and it worked without a hitch. To summarize the steps that I believe are critical to avoiding the issue you ran into:

  1. Ensure that the Photon is claimed properly. I used the Particle app on my phone and it worked as expected. From that point, as the Photon is reflashed to default and connected to Wi-Fi, it breathes cyan.

  2. Copy and paste the code from Tutorial 1 in the Infinity Mirror tutorial into a new program in the online IDE. After following the library include step, if you go to the devices tab, you should see your newly claimed photon their breathing cyan.

  3. Hit ‘Flash’ and you’ll see the flashing process take place. Your photon will reset, and the default code (which all photons are shipped with to save the hassle) will cause the code to run without connecting to your WiFi. The status LED will breathe white.

You can see the details that are indicative of a successful flash in the bottom right-hand corner of your IDE window:

I’ve also sent you an email so we can get it back out to you.

Worth noting that the Photon is currently claimed by Sam’s account; although you can claim it back just as easily again.