Investigating bricked MKR Zero boards and restoration of bootloader


After a quick discussion with Trent over the phone, here’s an attached file that outlines the issue we discussed and the background information that might help to troubleshoot it.

I’d be very, very, grateful if you could take a look and provide some advice as to what might be causing this issue and how I can recover my bricked MKR Zero and any future boards that I manage to brick as well.

Investigate bricked arduino MKR Zero - REV 1.pdf (707.0 KB)

Ideally we could identify the cause of why 3 boards have become bricked in the first place and adjust my process to prevent this from happening in the future.

Hello Adam,

For anyone following along, there are instructions that have been followed to attempt to reflash the bootloader on the bricked boards using these pins: SWDCLCK, SWDIO, SWDRESET, VCC and GND listed here that worked on 2/3 bricked boards:

I’d like to learn more about what could be causing the issue. Out of curiosity, are you still getting 3.3V and 5V stable on those rails on your last remaining still bricked MKR? I’d be keen to see whether on the 3V3 and +5V pins against GND whether the voltage is the right level and stable. A response of zero rather than seven when attempting to write the register seems suspiciously similar to the behaviour when below operating voltage.

1 Like


When the bricked board is isolated, i.e.
disconnected from programmer MKR Zero board AND bricked board then connected via micro-usb to the computer I get

  • Bright green power on led
  • +3.30v on Vcc
    +5.06v on 5V


Note that computer still doesn’t recognise USB device…can’t access, reset, program the board = bricked.

When I connect the programmer board to the bricked board via the soldered leads to the pads on the underside of the bricked board (as per the images in the PDF file), I get the following

  • Very weak green power-on led on bricked board
  • +3.27v on Vcc,
  • 2.01v on 5v rail

All voltages appear stable (although only using a multimeter to measure, not oscilloscope).