Core Electronics Forum

Is my Arduino Pro Mini 3.3v bricked? Or am I missing something?

I have recently bought an Arduino Pro Mini 328 - 3.3V/8MHz and FTDI Basic Breakout - 3.3V and it does not work. I have tried installing drivers for the FTDI Basic Breakout - 3.3V but it says that I already have the best drivers. Whenever I try to upload code I get back
“avrdude: stk500_getsync() attempt X of 10: not in sync: resp=0x3f”
I have tried the troubleshoots for this problem on the arduino website
But they do not work. There is a solder pad at the back and soldered the 3.3v pad to the middle pad. Before and after soldering did not change anything. I am quite positive that my code is correct as there is just a simple blink program. I have put it down below for good measure. Did I get sent a faulty board? Or is there a fix to this problem? Please help me. It is quite frustrating.



97svwrw4ass71
asuc2li3ass71

CODE:

int led = 13;

// the setup routine runs once when you press reset:
void setup() {                
  // initialize the digital pin as an output.
  pinMode(led, OUTPUT);     
}

// the loop routine runs over and over again forever:
void loop() {
  digitalWrite(led, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);               // wait for a second
  digitalWrite(led, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);               // wait for a second
}
1 Like

Deleted my original post.
I have not used the Pro Mini or the Sparkfun FTDI programmer. But I have used the FTDI Friend (link below) and a Pro Trinket. I well know how frustrating it can be.
In my original reply I thought it may have been the Programmer (AVRISP mkII), but when I checked my records that is one is I used to program the Pro Trinket.

The 3V3/5V pad is to change the voltage the Pro Mini uses. By default 3V3 is connected. Soldering the pad would not make any difference. To change to 5V, the small track between the middle pad and the 3V3 pad would have to be cut; and the middle pad soldered to the 5V pad. You can use a multi meter to confirm connectivity.

The program code is not the problem, it is the connection between the PC, FTDI board (Programmer) and the Pro Mini. This can fail for a number of reasons.

Big difference between the two boards is use of DTR by Sparkfun and RTS by Adafruit. This signal causes the micro on the Pro Mini to switch into bootloader mode by toggling the reset line momentarily.

If the PC software is switching the RTS line then it would fail as the Pro Mini would not get switched to bootloader mode.
If there is no bootloader in the Pro Mini to respond then it would fail. (installing a new bootloader is a whole different post)

Do the TX RX lights on the FTDI board light up at all ?? Even briefly.

It is quite hard to give adequate answers as there is so much that can cause it not to work. And the error codes are not explained anywhere.

Regards
Jim

2 Likes

Yes the RX and TX do light up but only when I plug it into my pc.

Hi Hugh,

Thanks for posting!

If you use the Serial monitor in order to send some output over to your Pro Micro (just any random text will do) are your TX and RX led illuminating?

Just curious to see whether there may be an issue with the FTDI chip on your particular board (I haven’t seen it happen on the SparkFun boards before, but sometimes there are defective/counterfeit chips on other boards)

2 Likes

Now its my turn to be frustrated.
Tried the Pro Trinket and FTDI Friend to see if I could get a clue as to why yours is not working. Well it didn’t work, and I don’t remember how I originally programmed it, and my documentation is lacking for the two projects where I used the Trinket. Sometimes my documentation is great, other times it is pretty woeful.

The TX & RX lights flash upon power up and the red light blinks once for each of the 10 attempts before it fails with error codes like yours. Both devices still work ok though, indicating no change to the program.

Might be the Pro Trinket needs to be programmed a different way and I have forgotten how. Will have to look into it. I wasn’t too impressed with the Pro Trinket and never bought a Pro Mini.

I highly recommend the following as a small micro, programming it is pretty easy and it is just as good as the Adafruit ones.

EDIT: Must be a bad day for me, I had the cable around the wrong way. It works ok now. (relief)
So still no closer to finding a solution. From what you have posted Hugh it should work, coupled with an investigation of Adafruit and Sparkfun tutorials. Maybe it is a bad FTDI chip.

Regards
Jim

3 Likes

@Bryce Yes, when I send text over it the TX pin illuminates briefly.

1 Like

There are 2 LEDs on the Pro Mini board. Red - VCC power, Green - digital pin 13.
When you power on the Pro Mini or press the Reset button does the Green LED flash or flicker.
The trouble shooting guide says if this does not happen it could mean the Pro Mini has lost its bootloader. Without the bootloader it will not respond to the FTDI board. (bricked as your title says)

7. Press the reset button and see if the LED blinks. If the LED doesn’t blink there is a high chance that the bootloader of your board is corrupted.

The bootloader can be reinstalled but not with the FTDI Programmer, the process is a little tricky and
has many traps for the unwary.

The FTDI TX LED flashing when you send data means the PC connection to it is probably ok.
Without another Pro Mini it is hard to say if this one is ok or not.

Have you tried the loop back test as per the troubleshooting web page, this proves the FTDI board is sending and receiving data ok and therefore eliminates it as a problem ??

Regards
Jim

3 Likes

The LED blinks yes.

What is the loop back test? I do not recall reading about that.

1 Like

I have just tried it with my brothers laptop. It has the same problem.

1 Like

The link below is from the Arduino help website. It is for testing the TX & RX of the Arduino but you could use it to test the FTDI Basic board.
Removed the FTDI board from the Pro Mini and use a jumper wire to connect the TXO & RXI pins. When you send something from the Arduino Serial Monitor both LEDs should flash briefly and what you send should appear in the Serial Monitor screen. If you try it without the jumper only the the TXO LED should flash and nothing will show in the monitor.

If this works the FTDI Basic board is ok and the problem could be in the Pro Mini. The chip on the FTDI board just converts USB signals to serial signals. Its is not too smart.

I tried the above with the FTDI Friend and it works ok.

When you try to program the Pro Mini does the LED blink as well, if only briefly ?? This would indicate the DTR line is being toggled correctly to switch the Pro Mini into bootloader mode.
As I previously said the difference between the FTDI Basic and the FTDI Friend is use of the DTR / RTS line. If the DTR line is not getting toggled, then bootloader mode would not be activated.

Anyway, let me know how you go and I’ll see if I can come up with any more options.
Cheers
Jim

PS It looks like the Pro Mini and FTDI Basic are functioning but not talking to each other.

1 Like

Just thought of something else.
You could try changing the programmer to “AVR ISP” from “AVRISP mkII”.
There is a difference in the configuration file between each of them. (see text below)
The parameter avrispmkii.program.extra_params=-Pusb has not worked with some drivers and boards.

Regards
Jim

avrisp.name=AVR ISP
avrisp.communication=serial
avrisp.protocol=stk500v1
avrisp.program.protocol=stk500v1
avrisp.program.tool=avrdude
avrisp.program.extra_params=-P{serial.port}

avrispmkii.name=AVRISP mkII
avrispmkii.communication=usb
avrispmkii.protocol=stk500v2
avrispmkii.program.protocol=stk500v2
avrispmkii.program.tool=avrdude
avrispmkii.program.extra_params=-Pusb

2 Likes

I tried it with that and it didn’t work. I am really not sure where the problem lies. I might just get an Arduino nano.

1 Like

Yes the FTDI passed the loopback test.

1 Like

Yes, was a long shot. The problems that used to exist with drivers and boards have pretty much been fixed. I really think your Pro Mini is working as a micro but the bootloader is corrupted or something.

If it was mine I would try reloading the bootloader, I have two programmers that can do that and have done it many times before on other Arduino devices.

The FTDI loopback working shows that there should not be any problem with it.

Probably, buying another device at this stage, might be the better option. If the Pro Mini has never worked I might talk to Core Electronics to see if they can load a new bootloader. Sometimes it can be as simple as a 12MHz bootloader in a 16MHz Arduino. The serial speeds would just be wrong. Or the bootloader was never tested in manufacture; but I have never purchased a product for Core Electronics that did not work first time. Every time it has been me that has stuffed it and then learnt how to fix it, LOL.

All the best
Jim

3 Likes

Thank you very much for trying to troubleshoot this problem, Jim. I really appreciate it :smiley:

2 Likes