Myoware 2.0 Muscle Sensors

I have been working with the new model of the Myoware Muscle Sensors and having trouble getting them to work.

  • I can get a signal from them, but it only changes when adjusting the gain. I can’t seem to get any change in the signal from muscle flexion.

  • I have tried using several different pieces of the same model in case the problem was unique to one of the pieces I had. I am reliably reproducing the same problem.

Previously I used this model:

  • They worked fantastically and produce a reliable trace when I graphed the output.
  • I used both models side by side on the same muscle area, with the same microcontroller and the same cables.

I must be doing something wrong with the new chips. I have exhausted all of the troubleshooting tips on the quick-start guide.

Please help!

1 Like

Hi Duncan,

Thanks for letting us know! Looks like we received a bad batch.

We’ll get back to you via email with instructions for a return, and we’ll get in touch with SparkFun to make sure the next batch we get is good.