New Pico not booting

Hi All,

I recently purchased two new Raspberry Pico’s. One with headers soldered on and one without.
I have tried to boot both into file-system mode by pressing the BOOTSEL button and attaching the USB with no luck. I’ve used four different USB to Micro USB cables and tried on different laptops/desktops.

Any suggestions as to why I can’t get them to boot?


Holding BootSEL whilst plugging in USB.

Loading thonny with Raspberry Pico Interpreter

Picos not recognised.



Hi Andrew,

When plugging in the Pico do any file systems pop up in Windows Explorer?
When first flashing the firmware you shouldn’t have to hold down the BOOTSEL button, plug in and wait a second and the file system on the Pico should open up.

Another good test is to make sure the micro USB cables have both power and data - looking into the end of the cable and seeing 4 pins is a quick check.

Let us know how you go!


Hi Liam,

No filesystems pops up under explorer, nothing happens - either, whist holding the BOOTSEL button or not.

With the USB - is it 4 pins on the USB or Micro USB side. Hard to take a photo as the focus is not great. I have 4 pins on the USB side and 5 on the micro USB side.

Kind Regards


Hi Andrew,

Just on the off chance, would you happen to have a third Pico you could try out?

The BOOTSEL feature can’t be modified by the end user, so it definitely should be functional.



Hi Andrew
A bit hard to do continuity checks to ascertain whether the cables are charge only or full data cables as the connector contacts are a bit difficult to get to reliably.
I found in practise the best way is try to communicate with another device like a phone or something that is known to get a result. Some time ago I checked all of my USB cables with the micro connector and found about half of them to be charge only. I marked those so not to get confused later.
They all seem to have all the pins fitted so just looking at them is not going to be conclusive.
Cheers Bob


That’s normal - the pins are V_Bus (power), D+ (Data positive), D- (Data negative), Gnd (Signal Ground). The 5th pin in the micro USB is an ID pin for USB OTG.


Thanks all for your suggestions.

I spent the day rummaging through the house looking a cable after the 8th attempt, I found one that actually worked. Most of them worked with a mobile and attaching USB mass storage but for some reason not with the Pico? figure that one out. The one that worked came with a Jabra headset which should only need to charge … again who knows.

Anyway I now have access to the Pico! so all good!


I just happened to see this post, and I had the same issue. None of my 3 picos would show up. I tried several cables. I thought I was going crazy. The fourth cable worked. Perhaps there is something particularly finicky in the USB connector on the picos?


Hmm, this might need some more investigation. It’s definitely odd. My first suspicion is that there is something going on with the cables, the Pico, and the various OTG protocols or Accessory Charging Adaptor specifications. :thinking:

Certainly seems to be an edge case though as I’ve never run into it myself and I’ve used quite a few different cables with my Picos so far.


Hi Colin
You might have some “charge only” cables in the mix. Most of these don’t have the data wires in them, just 2, red and black.
Cheers Bob